Map Sensor Problems - Chevy Malibu Forum: Chevrolet Malibu Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-25-2014, 12:00 PM Thread Starter
CMF Rookie Member
 
Join Date: Mar 2010
Posts: 5
Map Sensor Problems

Hello,

I have been having problems with my 2009 LT 2.4L A6 Malibu. I had been having intermittent problems with svc traction and esc codes on the DIC for a while. Then it started starting having stuttering and acceleration problems. This finally caused engine codes p0106 and p0107.

These lead me to believe it was the map sensor. I replaced it and still have the same warning codes and engine codes. Next I decided to test the wires to the map sensor itself. They all seem to test OK. I get a voltage drop when a vacuum is applied to the sensor(green), my 5 volt line (grey) is reading 5 volts and I am getting 12V from the PCM (orange/black). All of the engine codes point to the map sensor but all of my test show that it is working fine.

Where would you go from here? The dealership has been little help, it took three trips for them to guess that it might be the map sensor. Unfortunately it is out of full warranty, only have powertrain left.

Thanks for any help

Last edited by jack0395; 01-25-2014 at 12:04 PM.
jack0395 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-26-2014, 05:21 AM
Administrator
 
DrivenDaily's Avatar
 
Join Date: Dec 2009
Location: Indiana
Posts: 11,928
Garage
Re: Map Sensor Problems

Search for "fretting corrosion" and see if that helps...


'11 LTZ, born Aug 2010, Fairfax, KS

V6/A6, Red Jewel Tintcoat / Cocoa-Cashmere, Sunroof
Mods: WeatherTech mats, CHMSL Pulser

How-to: LEDs in mirrors :: How-to: 1-Wipe Wash
How-to: Remote express windows up/down


Traded: '09 2LT Black Granite Metallic V6 / A6 at 20,058 miles
Lost: '11 LTZ RJT V6 / A6 in flood at 44K miles
Muffler mod on '09
DrivenDaily is online now  
Sponsored Links
Advertisement
 
Reply
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Malibu Forum: Chevrolet Malibu Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
MAP Sensor codes and service traction/ESC messages - related? LoyalMalibuOwner Problems/Service Issues/Troubleshooting (Generation 7) 3 11-04-2015 01:00 PM
Interior Map Lights lalibert Modifications (Generation 8) 14 06-12-2014 02:28 PM
New Map Sensor...Service ESC/Traction Control Light JimMalibu Problems/Service Issues/Troubleshooting (Generation 7) 4 12-27-2013 11:59 AM
05 4cyl, P0107, where is MAP sensor? johnd393 Problems/Service Issues/Troubleshooting (Generations 5 & 6) 2 05-24-2011 01:52 AM
TPMS sensor problems JeffreyRosskopf Wheels, Tires & Suspension (Generation 7) 2 04-12-2011 09:23 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome