High Mounted Stop Lamp Intermittent issue Solved! - Page 2 - Chevy Malibu Forum: Chevrolet Malibu Forums
 7Likes
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 19 (permalink) Old 10-13-2016, 04:47 AM
CMF Rookie Member
 
Join Date: Oct 2010
Posts: 9
Re: High Mounted Stop Lamp Intermittent issue Solved!

I saw several malibu cars here that has the same problem. There should be a recall for this.
jabin is offline  
Sponsored Links
Advertisement
 
post #12 of 19 (permalink) Old 10-13-2016, 06:34 PM Thread Starter
CMF Senior Member
 
Join Date: Nov 2008
Posts: 228
Re: High Mounted Stop Lamp Intermittent issue Solved!

There is a recall related to that brake light, but have nothing to do with the light. It has something to do with the BCM module. Here is the link to the recall procedure. You might want to try it first.

It is very simple. Also if your cruise control does not work, that indicates the issue is at BCM. I actually had this BCM issue . When that occurred, my cruise control did not work either.

If all the stop lamps do not work, then check the STOP Lamp relay #49 in the fuse box under the hood.
If all that are checked ok, the problem is likely at the lamp. Take your time to try the procedure. The whole day if you need to. It is low risk. but can take time, depending on your skills.

You did not say how much the dealer quoted for the job. But I would bet it is something between $400 - $600. The lamp itself costs about $150. The labor is 2 hours. so it is worth trying..

good luck

08 2LT White/Titanium, 4cyl/4spd
Born 04/08 Lake Orion
hoahai is offline  
post #13 of 19 (permalink) Old 10-14-2016, 07:02 AM
CMF Rookie Member
 
Join Date: Jan 2013
Location: Québec, Québec, Canada
Posts: 20
Re: High Mounted Stop Lamp Intermittent issue Solved!

Dear JABIN,

As HOAHAI have written, take tour time and everything will be fine.

Be patient ans you will save a lot of money!

The PDF is very well done.

Lessy2009

Chevy for Life
Lessy2009 is offline  
 
post #14 of 19 (permalink) Old 12-01-2016, 11:19 AM
CMF Rookie Member
 
Join Date: Oct 2010
Posts: 9
Mine is now Fixed with a toothpick. Thank you Though I just learned that the Service Tech of who misdiagnosed my car, broke the rear dash's plastic behind the metal bar... that was held by a plastic screw... I'll never trust them again.
jabin is offline  
post #15 of 19 (permalink) Old 12-01-2016, 12:35 PM
CMF Rookie Member
 
Join Date: Dec 2012
Location: Southeast, Pa
Posts: 22
Re: High Mounted Stop Lamp Intermittent issue Solved!

Great post I have the same issue and have had everything out up to the side panels. I was worried about them going back together, but I am going to try this.
Whale is offline  
post #16 of 19 (permalink) Old 02-19-2017, 12:39 PM
CMF Senior Member
 
repairman54's Avatar
 
Join Date: Jun 2012
Location: Montague, NJ
Posts: 215
Garage
Re: High Mounted Stop Lamp Intermittent issue Solved!

Well I'm on round 2 on my center brake light and here's what I found on mine.
Mine was intermittent, depending on temperature it would work, not work or be dimly lit. IE would work when car was cold but would stop working after interior warmed up.
On pulling out the light assy. and taking it apart I found what they call cold soldier joints on where the tin connector plates that the LED's are mounted on are attached to the printed circuit board that hold the power dropping resistors.
Using a lower heat pencil type soldier iron I re-soldiered the connections. So far, so good. I had the stick on the brake pedal and was in the rear seat playing with the 2 connectors and the wiring and by slightly flexing the light assy. I found my issue.
I would recommend this repair for the electrically savvy person, it may be too intense for the unskilled.
Being the light assy. is at least a $80 part I was gonna make the attempt on solving my issue or doing a cheaper retro fit.
If my repair doesn't hold up I'll post back.

John
"some suffer from insanity, I choose to enjoy it"
09 Malibu LS
11 Tahoe LTZ
16 Equinox LTZ 3.6
01 FLHR
Ski Doo's & Sea Doo
02 Malibu traded
67 Malibu sold
64 Malibu sold
07 Mustang GT 3 pedals sold
repairman54 is offline  
post #17 of 19 (permalink) Old 02-25-2017, 08:40 PM Thread Starter
CMF Senior Member
 
Join Date: Nov 2008
Posts: 228
Re: High Mounted Stop Lamp Intermittent issue Solved!

I was on my round 2 yesterday. I opened up the assembly but could not find a way to remove the board and the led lights. Attached are the pictures. Can you circle where you soldered the connections?

I still think that the problem is at the connection of the 2 prongs to the board. I would have resoldered them if I had been able to remove the board. I ended up doing the same thing. Just wedge the connectors with 2 plastic toothpick. Will see how long they would go this time.

I agreed that retrofitting would be a good permanent solution. Just keep the assembly housing, find an after market 12v led light like the below, and retrofit it in there.
White LED License Plate Light (9) LED
Attached Thumbnails
Click image for larger version

Name:	IMG_20170224_211323466.jpg
Views:	21
Size:	84.1 KB
ID:	45554   Click image for larger version

Name:	IMG_20170224_211355472.jpg
Views:	19
Size:	79.5 KB
ID:	45562  

08 2LT White/Titanium, 4cyl/4spd
Born 04/08 Lake Orion

Last edited by hoahai; 02-26-2017 at 04:56 AM.
hoahai is offline  
post #18 of 19 (permalink) Old 02-26-2017, 06:21 AM
CMF Senior Member
 
repairman54's Avatar
 
Join Date: Jun 2012
Location: Montague, NJ
Posts: 215
Garage
Re: High Mounted Stop Lamp Intermittent issue Solved!

I previously soldiered the connector prongs but it didn't help. I just ground away some of the plastic housing for access. I originally posted that as a cure.
That's when on the second attempt I found the bad joints on the printed circuit board where the tin led array connects to the board. Those can be soldiered easily from the ''green'' side of board. If you look closely at the board joint you may see a tiny gap in the soldier joint.
Wedging the connector just flexes the board so the array to board joint makes contact IMO. That's why I had the stick on the brake pedal so I could sit in the back and play with the wiring and the light assy. .
I can't access your pics on my laptop to circle anything (not on my home desktop) but you will see where the shiny "tin" led array prongs go through and connect to the green board.
Mine has been fine since my last posting.

John
"some suffer from insanity, I choose to enjoy it"
09 Malibu LS
11 Tahoe LTZ
16 Equinox LTZ 3.6
01 FLHR
Ski Doo's & Sea Doo
02 Malibu traded
67 Malibu sold
64 Malibu sold
07 Mustang GT 3 pedals sold
repairman54 is offline  
post #19 of 19 (permalink) Old 02-26-2017, 04:35 PM Thread Starter
CMF Senior Member
 
Join Date: Nov 2008
Posts: 228
Re: High Mounted Stop Lamp Intermittent issue Solved!

Thanks for your quick reply. I now understand what you did. Will look into it next time, when the light went bad again.

08 2LT White/Titanium, 4cyl/4spd
Born 04/08 Lake Orion
hoahai is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Malibu Forum: Chevrolet Malibu Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
high mounted stop lamp works when cold not when warm sirdeeker Problems/Service Issues/Troubleshooting (Generation 7) 13 02-11-2016 09:13 AM
High mounted brake light failure sirdeeker General Discussion (Generation 7) 15 08-23-2014 04:34 AM
Wiper stop Hang up when on intermittent. lost Problems/Service Issues/Troubleshooting (Generation 7) 3 05-04-2014 08:57 AM
Problum Solved!: High Idle 2000 Malibu LS Cope337 Problems/Service Issues/Troubleshooting (Generations 5 & 6) 3 01-07-2014 05:51 PM
High Mount Stop Lamp Failure. ElantraMax Problems/Service Issues/Troubleshooting (Generation 7) 6 09-29-2012 04:56 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome