2001 Malibu Hazard Lights [Archive] - Chevy Malibu Forum: Chevrolet Malibu Forums

: 2001 Malibu Hazard Lights


skratchmo
03-12-2009, 10:41 PM
Hey all like the title says I have a 2001 Malibu. So you know the clicking sound your hazard lights/turn signals make when you turn them on right...for a long time now my hazards will just start clicking. They are not on nor do they turn on when the clicking starts. Sometimes it will be a slow click and sometimes its very fast. Does anyone know what might be causing this problem and possibly what to do about it?

slhaas
03-13-2009, 10:02 AM
Need a new flasher? That is a simple part from a auto parts store. Usually by the fuses in your car.

Malibu Glow
03-20-2009, 05:54 PM
slhaas, this is not a typical hazard flasher on the N-body Malibu's. The Hazard switch itself IS the flasher as well. There was a TBS a few years back from GM on the Hazard flasher malfunctioning and GM would replace it free, now I doubt that you can go in and ask for this now but you can try. The cost of the part is around $20.00 but you have to get it through the dealer and not available through any parts store that I know of. I've replaced mine two years ago cause it malfucntioned and haven't had a problem since.

slhaas
03-23-2009, 02:37 PM
It is part of the switch? Weird. How do you change it out?

Do you know if the new generation is this way too?

Malibu Glow
03-24-2009, 08:17 PM
Well for the N-body Malibu's this is how GM did the hazzard and flasher as one part, I don't think they kept it like that on the newer models but the N-body had a recall on it from GM to replace the faulty hazzard switch. Replacing it isn't too bad the whole trim panel that goes around the gauge cluster and reaches over to the passenger side needs to be carefully popped of the dash, there are two screws at the upper portion of the gauge cluster that do need to be removed first though.

Slide81
10-31-2009, 01:29 AM
I'm having a possibly related problem with my 03 Malibu. Turn signals want to work now and then. Such as make a 20 minute drive and they work fine the entire trip. Get back in the car when done and try to drive home and they might blink once or twice and then just stop. Or not blink at all. Usually when it does this I can hit the 4ways switch and it works, but not always. Sometimes it doesn't do anything either. Any thoughts?

Macleod52
10-31-2009, 04:18 AM
If this is the same issue that plagued the Grand Am's/Alero's, it's not your hazard switch, it's the multifunction switch. I believe you may be able to fix it by just putting some dielectric grease on some connectors, but I can't remember. The symptoms are that it sounds like your turn signals come on intermittently.

Take a look here (http://www.grandamgt.com/forum/showthread.php?t=50126&highlight=turn+signal) to see if this works.

Malibu Glow
10-31-2009, 11:37 AM
No Macleod, it's gonna be the hazzard switch on the Malibu, they combined the flasher and the hazzard switch as one part, there is no flasher in any fuse box in the car. There was a TSB on this issue from Chevrolet!!

I had this happen to mine and once I replaced the Hazzard/flasher switch everthing worked fine!

Macleod52
10-31-2009, 01:13 PM
No Macleod, it's gonna be the hazzard switch on the Malibu, they combined the flasher and the hazzard switch as one part, there is no flasher in any fuse box in the car. There was a TSB on this issue from Chevrolet!!

I had this happen to mine and once I replaced the Hazzard/flasher switch everthing worked fine!

Well, do the hazzard switch first since it's only $20, but if that doesn't fix it then it's the multifunction switch. It's a common problem on the N-bodies.

Malibu Glow
11-01-2009, 06:40 AM
Well, do the hazzard switch first since it's only $20, but if that doesn't fix it then it's the multifunction switch. It's a common problem on the N-bodies.

Hmm, being on three different Malibu sites for the past 5 years (United Malibu's, Malibuclub.ca and MP Racing), I've never heard of any Malibu owner having a problem with their multifunction switch, it has always been the hazzard/flasher switch.

Macleod52
11-01-2009, 02:30 PM
How similar is the N-body malibu's compared to the Grand Am/Alero? If they're similar, then I'm sticking with my answer, but if they just share the same chasis then I could be wrong.

I know I replaced the hazzard/flasher switch in my Grand Am because of the TSB, but that didn't fix it and I had to replace the switch.

Malibu Glow
11-01-2009, 02:34 PM
Well I guess the Malibu hasn't had the issue as the Grand Am or Alero, no one on the other sites has ever posted that they had problems with the muti-function switch. Certain parts are shared between the different models but there are some differences in some things.

Slide81
11-17-2009, 06:03 PM
Best suggestion I can see is www.GMPartsDirect.com They have the replacement hazard switch for $14.96 ^^

00Mali
11-20-2009, 07:02 AM
How similar is the N-body malibu's compared to the Grand Am/Alero? If they're similar, then I'm sticking with my answer, but if they just share the same chasis then I could be wrong.

I know I replaced the hazzard/flasher switch in my Grand Am because of the TSB, but that didn't fix it and I had to replace the switch.

I'm going to have to agree with macleod here. I'm not particularly familiar with malibus but I've had plenty of experience on other cars and I would bet you 10 to 1 that it's the multifunction switch

00Mali
11-20-2009, 02:07 PM
I was talking to a buddy of mine who has an Explorer who had the exact same problem you described and he said for him that it was actually the connectors on the pins that pugged into the multifunction switch started losing contact for some reason or another...but he just did a hillbilly fix since he's a cheap sob:D

Malibu Glow
11-20-2009, 09:22 PM
Hey all like the title says I have a 2001 Malibu. So you know the clicking sound your hazard lights/turn signals make when you turn them on right...for a long time now my hazards will just start clicking. They are not on nor do they turn on when the clicking starts. Sometimes it will be a slow click and sometimes its very fast. Does anyone know what might be causing this problem and possibly what to do about it?

Guess you need to re-read his post then! It is NOT due to the multifunction switch it is with the Hazard/turn signal flasher. This is what has happened on many Malibu's from 97-01 and was covered in a TSB, too bad I don't have the TSB number.

impactwrench
01-11-2010, 07:42 PM
My 2002 is doing this too. I would tend to think its the hazard button because when its acting up my flashers wont work either. Good to know its a cheap fix, but dang, why do I have to take the whole dash apart?

Its not too bad when I have to take out the recirc button and clean that every few months.

impactwrench
01-19-2010, 07:58 PM
I was going through some files tonight and found the TSB letter from GM from 2006 that says there is a 10 year 150k warranty on turn signals if they fail. Ima get mine fixed for free!