2010 Malibu LTZ - 2 New Electrical Problems - Chevy Malibu Forum: Chevrolet Malibu Forums
Auto Insurance

» Featured Product
Wheel & Tire Center


ChevyMalibuForum.com is the premier Chevrolet Malibu Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 02-05-2012, 06:40 AM   #1
Bedbug
CMF Senior Member
2010 Malibu LTZ
Diamond White
 
Join Date: Jan 2010
Posts: 176
Gallery: 0
Default 2010 Malibu LTZ - 2 New Electrical Problems

Guys

I have two new electrical problems :

1) Every once in a while my service airbag light goes on and the chime rings. This happens while I'm driving , it will stay on for 3 to 4 minutes then the light goes off. Now I know there's a problem with a lose cable under the drivers seat, and mine was fixed but can anything else cause this?

2) Here is the annoying one-- The radio control buttons on the right side of the steering wheel. My volume up button (the very top one) when tapped with my finger actually LOWERS the volume. The Volume down button (the second button) actually changes my channels. The third and fourth buttons (which are to change the stations) some times works correctly and sometimes work backwards.

Has anyone else encountered any of these problems -- or is my car playing a cruel joke on me ????
__________________
Bedbug
Bedbug is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-05-2012, 08:53 AM   #2
Rodents
ASE Certified Technician
2011 Malibu 2LT
Red Jewel Tintcoat
 
Join Date: Aug 2011
Location: Souderton, PA
Posts: 3,075
Gallery: 0
Default Re: 2010 Malibu LTZ - 2 New Electrical Problems

Quote:
Originally Posted by Bedbug View Post
1) Every once in a while my service airbag light goes on and the chime rings. This happens while I'm driving , it will stay on for 3 to 4 minutes then the light goes off. Now I know there's a problem with a lose cable under the drivers seat, and mine was fixed but can anything else cause this?

2) Here is the annoying one-- The radio control buttons on the right side of the steering wheel. My volume up button (the very top one) when tapped with my finger actually LOWERS the volume. The Volume down button (the second button) actually changes my channels. The third and fourth buttons (which are to change the stations) some times works correctly and sometimes work backwards.
#1 - What was done to your vehicle for the wiring under the seat if you know? There were a couple recalls, the early ones just got inspected and dielectric grease on the connector and that was about it. The later ones got new connectors no matter what. So, if you didn't get new connectors, you should start there. If you PM me the last 8 digits of the VIN, I'll see if there's any open recalls so you can get it done for free. With the key off, go under each seat and disconnect and reconnect the yellow connectors a few times and see if that helps. May be fretting corrosion, of course there could be other issues.

#2 - Probably the steering wheel button assembly is just gone bad. Radio works fine from the actual on the radio controls, right? The steering wheel controls are just a bunch of resistors and pressing a button completes a circuit with a predetermined resistance. If the resistance is out of spec, the command won't be interpreted correctly. Should be serviced separately but you need to remove the air bag module to do it.
Rodents is offline   Reply With Quote Quick reply to this message
Old 02-11-2012, 05:48 AM   #3
Chevrolet Customer Svc
Verified Chevy Representatives
 
Chevrolet Customer Svc's Avatar
 
Join Date: Aug 2010
Posts: 2,641
Gallery: 0
Default Re: 2010 Malibu LTZ - 2 New Electrical Problems

@Bedbug, I have read your post about your new situations with your Malibu. I see that rodents has posted a reply to your issues; I was wondering how things are going? Did you have to get the vehicle into the dealership?

Michelle, Chevrolet Customer Service
__________________

Available Monday-Friday

Chevrolet Customer Svc is offline   Reply With Quote Quick reply to this message
Old 02-13-2012, 12:06 PM   #4
Bedbug
CMF Senior Member
2010 Malibu LTZ
Diamond White
 
Join Date: Jan 2010
Posts: 176
Gallery: 0
Default Re: 2010 Malibu LTZ - 2 New Electrical Problems

Rodent

Yes you are correct the wires under the driver seat are pulling away from the connector. I reconnected them tightly and taped them real good -- so far so good.

Michelle

After my battery went dead the dealer jumped and tested it and so far button is working fine. I will keep you posted.
__________________
Bedbug
Bedbug is offline   Reply With Quote Quick reply to this message
Old 02-13-2012, 01:18 PM   #5
greenman
ASE Certified Technician
 
Join Date: Nov 2010
Posts: 1,448
Gallery: 0
Default Re: 2010 Malibu LTZ - 2 New Electrical Problems

Quote:
Originally Posted by Bedbug View Post
Yes you are correct the wires under the driver seat are pulling away from the connector. I reconnected them tightly and taped them real good -- so far so good.
Sounds like the harness may be made a little short. Or there's a harness routing issue.
greenman is offline   Reply With Quote Quick reply to this message
Old 02-13-2012, 04:50 PM   #6
Rodents
ASE Certified Technician
2011 Malibu 2LT
Red Jewel Tintcoat
 
Join Date: Aug 2011
Location: Souderton, PA
Posts: 3,075
Gallery: 0
Default Re: 2010 Malibu LTZ - 2 New Electrical Problems

Quote:
Originally Posted by Bedbug View Post
Yes you are correct the wires under the driver seat are pulling away from the connector. I reconnected them tightly and taped them real good -- so far so good.
That is something that should get addressed while you're in warranty. There are recalls for wiring issues there under the seat. You may or may not be eligible for the recall depending on the recall status of your vehicle, however base factory warranty should cover it as well.
Rodents is offline   Reply With Quote Quick reply to this message
Old 01-01-2013, 07:33 AM   #7
zaxmozen
CMF Rookie Member
2010 Malibu
White Pearl
 
Join Date: Apr 2011
Location: Qatar
Posts: 12
Gallery: 0
Default Re: 2010 Malibu LTZ - 2 New Electrical Problems

Bedbug

I've had the same problem with the airbag before but after a while it's back to normal - NO MORE ANNOYING AIRBAG LIGHT.

As for the volume button I am experiencing the same problem now. Have you resolved it?

Appreciate your input.
zaxmozen is offline   Reply With Quote Quick reply to this message
Old 01-01-2013, 11:52 AM   #8
greenman
ASE Certified Technician
 
Join Date: Nov 2010
Posts: 1,448
Gallery: 0
Default Re: 2010 Malibu LTZ - 2 New Electrical Problems

Quote:
Originally Posted by zaxmozen View Post
As for the volume button I am experiencing the same problem now. Have you resolved it?
Button contacts are going bad. Just replace the steering wheel button assy. on that side.
greenman is offline   Reply With Quote Quick reply to this message
Old 01-07-2013, 06:55 AM   #9
Bedbug
CMF Senior Member
2010 Malibu LTZ
Diamond White
 
Join Date: Jan 2010
Posts: 176
Gallery: 0
Default Re: 2010 Malibu LTZ - 2 New Electrical Problems

Quote:
Originally Posted by zaxmozen View Post
Bedbug

I've had the same problem with the airbag before but after a while it's back to normal - NO MORE ANNOYING AIRBAG LIGHT.

As for the volume button I am experiencing the same problem now. Have you resolved it?

Appreciate your input.
Ok the airbag light problems stemed from a wiring harness under the drivers seat . It was to short and it would unplug from its connector. You may want to take a look at that. As for the buttons -- I was told by a mechanic at Chevy that it was an indication that your battery was going weak. Now I had the battery, alternator and starter replaced and all the wiring in between. Since then I have not had the radio button problem, since.

Have you had any other problems ? Not starting quickly or starting weak ? etc.

Good luck
Bedbug
__________________
Bedbug
Bedbug is offline   Reply With Quote Quick reply to this message
Old 01-07-2013, 09:15 PM   #10
zaxmozen
CMF Rookie Member
2010 Malibu
White Pearl
 
Join Date: Apr 2011
Location: Qatar
Posts: 12
Gallery: 0
Default Re: 2010 Malibu LTZ - 2 New Electrical Problems

Quote:
Originally Posted by Bedbug View Post
Ok the airbag light problems stemed from a wiring harness under the drivers seat . It was to short and it would unplug from its connector. You may want to take a look at that. As for the buttons -- I was told by a mechanic at Chevy that it was an indication that your battery was going weak. Now I had the battery, alternator and starter replaced and all the wiring in between. Since then I have not had the radio button problem, since.

Have you had any other problems ? Not starting quickly or starting weak ? etc.

Good luck
Bedbug
Bedbug

Thank you for your input. Surprisingly withouth even touching anything, the airbag lights & the radio control buttons are back to normal. I have never experienced any starting problems and hopefully not in the future.

Cheers
zaxmozen is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Malibu Forum: Chevrolet Malibu Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2010 Malibu Problems cm23 Problems/Service Issues/Troubleshooting (Generation 7) 8 02-10-2014 11:56 AM
2010 Malibu problems hjlint Problems/Service Issues/Troubleshooting (Generation 7) 6 01-26-2012 06:22 AM
2010 LTZ OLM problems mel Problems/Service Issues/Troubleshooting (Generation 7) 11 12-27-2011 04:33 PM
06 malibu max ls Electrical problems mcmastl Problems/Service Issues/Troubleshooting (Generations 5 & 6) 14 08-31-2011 01:51 PM
2010 Radio button problems Melodie Problems/Service Issues/Troubleshooting (Generation 7) 4 06-20-2011 10:32 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 06:37 PM.



Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
The Chevy Malibu Logo, Chevy Malibu Typeface and Chevy Logo are Trademark General Motors. We are in no way affiliated with General Motors, we are simply an enthusiasts' site.