2009 service ECM / Traction control - Chevy Malibu Forum: Chevrolet Malibu Forums
Auto Insurance

» Featured Product
Wheel & Tire Center


ChevyMalibuForum.com is the premier Chevrolet Malibu Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 01-15-2013, 11:12 AM   #1
Reallove
CMF Rookie Member
2009 Malibu LS
tan
 
Join Date: Jan 2013
Location: Rochester, NY
Posts: 9
Gallery: 0
Default 2009 service ECM / Traction control

I am having the same problem with my local dealer and the EMC and traction in my 2009 Malibu LS. I was diagnosed by my local dealer that the code was the traction switch and then the map sensor when the problem still existed after changing the traction switch till this day I am having the same problems. Please help...
Reallove is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-15-2013, 01:24 PM   #2
greenman
ASE Certified Technician
 
Join Date: Nov 2010
Posts: 1,448
Gallery: 0
Default Re: 2010 LTZ service ECM / Traction control

Quote:
Originally Posted by Reallove View Post
I am having the same problem with my local dealer and the EMC and traction in my 2009 Malibu LS. I was diagnosed by my local dealer that the code was the traction switch and then the map sensor when the problem still existed after changing the traction switch till this day I am having the same problems. Please help...
I would need the actual codes & a more detailed history to be of much help.

Last edited by greenman; 01-17-2013 at 12:33 PM.
greenman is offline   Reply With Quote Quick reply to this message
Old 01-15-2013, 02:55 PM   #3
DrivenDaily
Administrator
2011 3.6/ A6 LTZ
Red Jewel Tintcoat
 
DrivenDaily's Avatar
 
Join Date: Dec 2009
Location: Kentucky
Posts: 9,748
Gallery: 6
Garage
Cool Re: 2010 LTZ service ECM / Traction control

Quote:
Originally Posted by Reallove View Post
I am having the same problem with my local dealer and the EMC and traction in my 2009 Malibu LS. I was diagnosed by my local dealer that the code was the traction switch and then the map sensor when the problem still existed after changing the traction switch till this day I am having the same problems. Please help...
Quote:
Originally Posted by greenman View Post
Please start a new thread with your issue. Moved to new thread...

Also, I would need the actual codes & a more detailed history to be of much help.
Codes and other pertinent details are needed by techs in shops, too...
__________________

'11 LTZ, born Aug 2010, Fairfax, KS

V6/A6, Red Jewel Tintcoat / Cocoa-Cashmere, Sunroof
Mods: WeatherTech mats, CHMSL Pulser

How-to: LEDs in mirrors :: How-to: 1-Wipe Wash
How-to: Remote express windows up/down


Traded: '09 2LT Black Granite Metallic V6 / A6 at 20,058 miles
Lost: '11 LTZ RJT V6 / A6 in flood at 44K miles
Muffler mod on '09
DrivenDaily is offline   Reply With Quote Quick reply to this message
Old 01-17-2013, 09:13 AM   #4
Chevrolet Customer Svc
Verified Chevy Representatives
 
Chevrolet Customer Svc's Avatar
 
Join Date: Aug 2010
Posts: 2,554
Gallery: 0
Default Re: 2009 service ECM / Traction control

Reallove,
If you would like for us to contact your dealership to follow up on this with them, please send us more details (your name and contact information, the last 8 digits of your VIN and mileage, and a summary of the situation) to the email address in our signature or by private message on the forum.

Sarah (Assisting Michelle), Chevrolet Customer Service
__________________

Available Monday-Friday

Chevrolet Customer Svc is offline   Reply With Quote Quick reply to this message
Old 01-17-2013, 06:38 PM   #5
repairman54
CMF Senior Member
2009 Malibu LS 2.4
Carbon Mist Met.
 
Join Date: Jun 2012
Location: Montague, NJ
Posts: 114
Gallery: 0
Default Re: 2009 service ECM / Traction control

I would unplug / plug the ABS module a few times and the same with the BCM and PCM .
With the neg. cable off the battery of course. That fixed a few weird problems with my car.
repairman54 is offline   Reply With Quote Quick reply to this message
Old 01-22-2013, 12:30 PM   #6
Reallove
CMF Rookie Member
2009 Malibu LS
tan
 
Join Date: Jan 2013
Location: Rochester, NY
Posts: 9
Gallery: 0
Default Re: 2009 service ECM / Traction control

Quote:
Originally Posted by Chevrolet Customer Svc View Post
Reallove,
If you would like for us to contact your dealership to follow up on this with them, please send us more details (your name and contact information, the last 8 digits of your VIN and mileage, and a summary of the situation) to the email address in our signature or by private message on the forum.

Sarah (Assisting Michelle), Chevrolet Customer Service
Thank you I sent you a private message.
Reallove is offline   Reply With Quote Quick reply to this message
Old 02-22-2013, 06:40 AM   #7
jhines82
CMF Rookie Member
2008 Malibu 2LT
Silver
 
Join Date: Oct 2011
Location: Atlanta, GA
Posts: 9
Gallery: 0
Send a message via Yahoo to jhines82
Default Re: 2009 service ECM / Traction control

I had the same issue on my 2008 2.4 4cyl. Engine would start stuttering, ESC/Traction would disable, and i would get Loss of Power message. Initially I thought it was a transmission problem, but I took it to the dealer and they replaced the Timing Valve Actuator. It seems to have corrected the problem, I havent had any issues since then.



Quote:
Originally Posted by Reallove View Post
I am having the same problem with my local dealer and the EMC and traction in my 2009 Malibu LS. I was diagnosed by my local dealer that the code was the traction switch and then the map sensor when the problem still existed after changing the traction switch till this day I am having the same problems. Please help...
jhines82 is offline   Reply With Quote Quick reply to this message
Old 03-15-2014, 10:19 AM   #8
Adeitse
CMF Rookie Member
 
Join Date: Mar 2014
Posts: 3
Gallery: 0
Default Re: 2009 service ECM / Traction control

I have the same problem as described by Reallove. Engine begins to stutter, Reduced Engine Power flashes on the DIC, and the Traction Loss icon also lights up.

The fault code has always been P1682.

To get the stuttering to stop, I would disconnect the battery for about 10 mins, (sometimes 20 mins), and reconnect and start the engine. EVERYTIME this has happened, and I have had to disconnect the battery, I have noticed that the tEmperature of the ECM has been extremely high (burning hot). And the battery too.

I was compelled to change Ignition coils, but he problem still persists.

Unfortunately for me, I have no GM or Chevy dealer here in Ghana to advise.

A friend who is certified to fix Ranfer Rover, BMW, Porsche and Mercedes and has a GM diagnostic equipment diagnosed the fault codes to be P1682 as earlier indicated.

I am losing interest in this car, an 09 Chevy Malibu LT with 77984 miles on the engine.

Your help will be appreciated.

Thanks.
Adeitse is offline   Reply With Quote Quick reply to this message
Old 03-15-2014, 01:25 PM   #9
DrivenDaily
Administrator
2011 3.6/ A6 LTZ
Red Jewel Tintcoat
 
DrivenDaily's Avatar
 
Join Date: Dec 2009
Location: Kentucky
Posts: 9,748
Gallery: 6
Garage
Default Re: 2009 service ECM / Traction control

Have you or your technician friend tried unplugging the BCM (not the ECM)? Search this forum for "fretting corrosion" and read about it before proceeding. You may find it interesting and helpful. What you do is up to you but it never hurts to learn what you can, especially about an issue that could be such a simple fix.
__________________

'11 LTZ, born Aug 2010, Fairfax, KS

V6/A6, Red Jewel Tintcoat / Cocoa-Cashmere, Sunroof
Mods: WeatherTech mats, CHMSL Pulser

How-to: LEDs in mirrors :: How-to: 1-Wipe Wash
How-to: Remote express windows up/down


Traded: '09 2LT Black Granite Metallic V6 / A6 at 20,058 miles
Lost: '11 LTZ RJT V6 / A6 in flood at 44K miles
Muffler mod on '09
DrivenDaily is offline   Reply With Quote Quick reply to this message
Old 03-17-2014, 03:17 PM   #10
Adeitse
CMF Rookie Member
 
Join Date: Mar 2014
Posts: 3
Gallery: 0
Default Re: 2009 service ECM / Traction control

Thanks DrivenDaily for the direction.

I took the car to my Tech Fiends' garage. Following the procedural guideline on treating Fretting Corrosion on the BCM, he cleaned the contacts on the BCM, and applied the dielectric grease (we got some from he1 pulstar spark plugs).

I took the for a test drive and for 2 hours, it performed well. Suddenly, the engine started stuttering with the "Service ESC" and "Engine Power Reduced" flashing on the DIC.

I took it back for a repeat procedure. The stuttering came back under 1 hour. By this time, I needed to go pick my daughter from school and so could not go back to the garage.

But, I am thinking replacing the Variable Valve Timing Actuator (intake and exhaust) might resolve it.

What do you all think.
Adeitse is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Malibu Forum: Chevrolet Malibu Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2010 LTZ service ECM / Traction control pinballfixer Problems/Service Issues/Troubleshooting (Generation 7) 3 02-05-2013 02:01 PM
Brake lights on/traction control service on. Budlab Problems/Service Issues/Troubleshooting (Generation 7) 3 10-30-2012 08:57 PM
Service Traction Control/ ECS Jimmyb1 Problems/Service Issues/Troubleshooting (Generation 7) 14 09-07-2011 03:54 PM
service traction control PSMITH Problems/Service Issues/Troubleshooting (Generations 5 & 6) 0 07-22-2011 11:25 AM
Service ECS, Service Traction control??? Yefeng Problems/Service Issues/Troubleshooting (Generation 7) 1 08-25-2009 09:28 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 09:51 PM.



Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
The Chevy Malibu Logo, Chevy Malibu Typeface and Chevy Logo are Trademark General Motors. We are in no way affiliated with General Motors, we are simply an enthusiasts' site.