Chevrolet Malibu Forums banner

2006 Chevy Malibu Problems

15007 Views 5 Replies 4 Participants Last post by  Starship
So I purchased the car about a month ago, after a test drive I noticed some things needed to be fixed and the dealer was able to fix them. This is what was fixed, the driver/passenger side door lock buttons would only unlock, not lock. The steering wheel would jerk sometimes when turning and the ABS light would flash for a split second.

After those were fixed, the car had no problems for about a week (funny, huh? everything always works perfectly at the dealership, but then you take it home and the real problems show)

Anyways, I was putting on seat covers one day, decided to put the car in my neighbor's drive way while i installed them, after I finished installing them, I try to start the car and it wouldn't start, it would crank and even let out black smoke from the exhaust but it wouldn't start. After I had a friend come take a look at it, and giving it gas while starting the car, it started and let out white smoke for a couple hours, but after a 20minute drive all seemed well.

After that incident, now it starts 95% of the time, the other 5% it would start then stall, unless I give it gas. I took it to a mechanic and he said no tune up is needed, and the problem isn't the fuel pump, it could be the ignition switch, but he's not 100% sure and doesn't want to replace it unless he is 100% sure.

Another problem I'm having is the doors would seem to magically unlock themselves while I'm driving. I don't know what could be causing that, but that issue recently escalated, the doors now unlock themselves when the car is off. Earlier today I went to my car, and just pulled the door handle and the car opened but the alarm went off (I'm 110% sure I locked it the night before).

Is anyone experiencing these issues? or does anyone know what can be done to fix them?

I really appreciate any help.
See less See more
Status
Not open for further replies.
1 - 2 of 6 Posts
@whoflungpoo the car was bought at 88,000 miles, it's now at 89.5.

@Driven Daily,
My windows were actually tinted the day I got the car, I have to look into that, it's just hard to find a good mechanic whose thorough and can be trusted around my area that doesn't charge $100/hr for labor.

@Starship,
I haven't seen any white smoke since that day, I thought it might be from just changing the type of gas the car was used to for the first 88000 miles. I usually use regular, I'm not sure what the previous owner uses. correct me if I'm wrong, please.

Also, I'm not sure if this is on all chevy models, but it doesn't seem normal to me. When I reverse and attempt to parallel park, it seems as if I lose power steering. I used to think it'd because I'm too close to the side walk, but last week I got out to check and I was a good 4 inches away.
1 - 2 of 6 Posts
Status
Not open for further replies.
Top