Chevrolet Malibu Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Was driving my Malibu the other week when all the sudden i heard a ding ding chime from the dash. I looked down and saw light come on by the tachometer that looked like a car with a lock thru its frame. It stayed on until i reached my destination. The next time i started my car, everything was normal, until a km or so later the ding ding happened again and i noticed the same light, except this time accompanied with it numerous features on the dash were glitching out! The fuel gauge was randomly loosing power, the info display was darting back and forward between "service esc" "inst fuel mileage" (what i normally have it set at) and something else like "trip distance and outside temp".... this would happen in roughly 15 second increments then go away.... then come back a minute later until i reached my destination. Note that the engine light never came on during this. The car also drove totally normal. The next time i went to drive somewhere, i turned the ignition key, the dash came on normally, upon starting the car, the dash cut out like its supposed to, but the starter did not respond. I immediately turned the ignition totally off and then back on again, the dash came on as per the norm, and further more the car started normally. This weekend i drove 250 plus kms and the issued did not come up.

Any incites into what i should check ?

My first thought was that it might be a poor battery connection. But the battery looks professionally installed, the clamps very tight, and white paste slathered onto it that looks factory.

The battery itself is also very healthy.

I checked the fuse box under the hood and everything seemed tight and visually clean. But maybe theres a gummed up connection ?
 

·
Administrator
2011 Malibu LTZ 3.6L V6 Red Jewel Tintcoat
Joined
·
20,479 Posts
How old is the battery?

Has it been discharged to dead or nearly dead, such as below 9 or 10 volts?

Has there been any work done on the IPC - instrument panel cluster - in the last year or so?

Have you noticed any rodent droppings or signs of life inside your car or under the hood?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Battery may be old, but it seems healthy, the battery has never gone dead in the years ive owned the car. No work has been done to the dash that i can see. No rodent issues either.


Today it tripped out again, however this time it was way worse. The speedometer was glitching out as well, traction control light was on, the dash was saying "traction control off", the ABS light was on, saying "service ESC" and heres the big difference, everytime the dash tripped out, the transmission shifted down a gear. 15 seconds later when the dash went mostly back to normal the tranny shifted back up.
This all occured while cruising down the road at around 60km/hr.
 

·
Administrator
2011 Malibu LTZ 3.6L V6 Red Jewel Tintcoat
Joined
·
20,479 Posts
"Seems healthy" won't work. You should have it load-tested, not just tested for voltage.

If there are internal issues, a load test should provide a realistic picture of what you have.

With modern cars, which are more like computers on wheels, a solid, strong battery is needed. When it starts to get old and/or is compromised somehow, it can cause issues in a number of unrelated areas.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top