Chevrolet Malibu Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
128 Posts
Discussion Starter · #1 ·
Hey friends,

My 13 Malibu 2.5 @ 90k kms randomly stalls when stopped. When the vehicle has stalled, the radio, lights, nav menus all continue to work perfectly, as if in acc mode. I shift to park, and it starts back up, but VERY roughly. And in general, the idle is very rough when in Drive. However in Park, the idle is smooth.

To attempt to rectify over the past 12 months, below are the things I've had done:
  1. Battery replacement
  2. Throttle body cleaning
  3. Computer update
  4. ECM calibration
The dealer tells me they won't do anything because it doesn't throw any codes. I've reached out to GM customer service, but they were no help. I'm bewildered at an establishment that cannot troubleshoot issues of the vehicles they sell. It's extremely frustrating. Sorry for the little vent.

I'm by no means a mechanic, but this is a huge safety concern for me. I hate stalling, especially when making a left turns. I'm seeking the advice of anyone who has experienced similar and what your fix was.

Thanks in advance.
 

·
Administrator
2011 Malibu LTZ 3.6L V6 Red Jewel Tintcoat
Joined
·
20,832 Posts
Starting in 2013, all GM engines in the Malibu switched from SPI (sequential port injection) to DI (direct injection). As such, the fuel no longer sprays on the backside of the intake valves to help keep them clean.

It's possible that your engine has some build-up that is leading to this condition you're experiencing. An inspection is due, and if the results show that you have a significant amount of goo, a cleaning is in order. Unfortunately, you won't be able to get it out of a bottle. The most highly endorsed method is to have them cleaned with crushed walnut shells at a shop, unless you are able to do it yourself. But most folks aren't.
 

·
Super Moderator
2016 Malibu 1LT 1.5T/6-speed 6T40
Joined
·
4,359 Posts
GM 2.5L engine: check intake manifold bolts for proper torque.
 

·
Registered
Joined
·
21 Posts
I had a similar issue with my car but I was throwing a code indicating that it was because of my exhaust or intake solenoid, can't remember which. Ended up replacing them both and it took care of the issue. Figured if one was bad, the other might go bad soon.
 

·
Registered
Joined
·
3 Posts
I had a similar issue with my car but I was throwing a code indicating that it was because of my exhaust or intake solenoid, can't remember which. Ended up replacing them both and it took care of the issue. Figured if one was bad, the other might go bad soon.
Had the same problem with mine and this cured the problem. I guess it is a common problem on some of these Malibu's. I tightened up the manifold bolts and hasn't stalled since.
 

·
Banned
2015 Chevrolet Malibu LT 1LT, 2.5L DOHC Ecotec, 6-speed Auto
Joined
·
109 Posts
The strange part is that you are not throwing any codes. A rough idle can be caused by quite a few things, and a couple of them have already been suggested.

As far as the intake valves being dirty, I am leaning that is less likely than a vacuum leak with loose intake manifold bolts.

With 90k km, you are only about 58,000 miles. The mileage seems a little too low, for the intake vales needing a walnut blast.

You can test the intake manifold for a vacuum leak, by leaving the car in Park and at idle. Remove the engine cover and spray carburetor cleaner along the surface of the manifold, where it mates to the cylinder head. IF your idle speed and idle quality changes, you have an intake gasket leak, and the bolts probably need retorqued.

If you decide to do this yourself, be careful at how much you torque the bolts, as the manifold is plastic and it could crack if the bolts are too tight.
 

·
Registered
Joined
·
8 Posts
Hey friends,

My 13 Malibu 2.5 @ 90k kms randomly stalls when stopped. When the vehicle has stalled, the radio, lights, nav menus all continue to work perfectly, as if in acc mode. I shift to park, and it starts back up, but VERY roughly. And in general, the idle is very rough when in Drive. However in Park, the idle is smooth.

To attempt to rectify over the past 12 months, below are the things I've had done:
  1. Battery replacement
  2. Throttle body cleaning
  3. Computer update
  4. ECM calibration
The dealer tells me they won't do anything because it doesn't throw any codes. I've reached out to GM customer service, but they were no help. I'm bewildered at an establishment that cannot troubleshoot issues of the vehicles they sell. It's extremely frustrating. Sorry for the little vent.

I'm by no means a mechanic, but this is a huge safety concern for me. I hate stalling, especially when making a left turns. I'm seeking the advice of anyone who has experienced similar and what your fix was.

Thanks in advance.
In the trunk there's a fuel pump control module passenger side .it sounds like an issue I had
 

·
Registered
Joined
·
1 Posts
Hey friends,

My 13 Malibu 2.5 @ 90k kms randomly stalls when stopped. When the vehicle has stalled, the radio, lights, nav menus all continue to work perfectly, as if in acc mode. I shift to park, and it starts back up, but VERY roughly. And in general, the idle is very rough when in Drive. However in Park, the idle is smooth.

To attempt to rectify over the past 12 months, below are the things I've had done:
  1. Battery replacement
  2. Throttle body cleaning
  3. Computer update
  4. ECM calibration
The dealer tells me they won't do anything because it doesn't throw any codes. I've reached out to GM customer service, but they were no help. I'm bewildered at an establishment that cannot troubleshoot issues of the vehicles they sell. It's extremely frustrating. Sorry for the little vent.

I'm by no means a mechanic, but this is a huge safety concern for me. I hate stalling, especially when making a left turns. I'm seeking the advice of anyone who has experienced similar and what your fix was.

Thanks in advance.
2015 malibu doing the same thing as yours and also not throwing any codes
 

·
Premium Member
Joined
·
3,341 Posts
2015 malibu doing the same thing as yours and also not throwing any codes
Check your intake manifold bolts for being loose. May be loose and leaking but not bad enough to set a code yet.
 
  • Like
Reactions: SilverSport
1 - 11 of 11 Posts
Top