Chevrolet Malibu Forums banner

41 - 42 of 42 Posts

·
Registered
Joined
·
2 Posts
I did not i checked the BCM wiring all good. I did notice that when I reset the codes, it keeps saying that it losses connection with the Electrical Brake Control Module, but the ABS light doesn't come on and the brakes work good. I took everything apart again and went on a mission to check the wiring for that EBCM and all looks good, I figured why not clean all the cloud connections while I'm their so chased the whole engine ground cables and cleaned them. The issue is still there with the EBCM but the car sure looks cleaner. Jaja. I was able to determine that I was low on brake fluid and it looks as its leaking from the brake pump tanks thing, and once I ran a diagnostic on the sensor it did say low and is stayed saying low even after I filled up the resuvore. I took of the sensor and there was no resistance or anything. I'm going to change the Brake Fluid Level Sensor but I don't think that whats doing all this. After driving the car for so long I did notice that the car seems to shut off after I get off the highway. Idk if its a temperature thing or what. At this point I made it clear that never again will I ever buy a Chevy car and you should stay away from them too specially the newer ones.

I would love to work on your car but we are to far apart jaja.
 

·
Registered
Joined
·
15 Posts
Just picked car up for mechanic. They say they can’t find anything wrong with it so they cleaned “everything” up, don’t ask me what everything is. They said they also added an additive. I started it up and it still has a rough start with hesitation, so looks like I will be car shopping this weekend and trading this #$%^& in. Any advice on what a good, reliable car is with a $15,000 budget?
 
41 - 42 of 42 Posts
Top