Chevrolet Malibu Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
ok guys so im new on this forum , but ive been having issues with my brakes , it has a little over 80k miles, abs started acting up and the pedal would drop a little and make a thump sound coming from the driver side front wheel..and then just today brake pedal got hard as I was driving and would barely stop, any ideas?
 

·
Super Moderator
Joined
·
2,072 Posts
Welcome and yikes! Could be several things, needs diagnosis and you shouldn't drive a car with severe brake malfunction. Seems like at least a loss of vacuum while driving considering that hard pedal. Could be a loose or torn hose, failing brake booster, failing aux vacuum pump.... no fault codes yet? Loosing any fluid?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Welcome and yikes! Could be several things, needs diagnosis and you shouldn't drive a car with severe brake malfunction. Seems like at least a loss of vacuum while driving considering that hard pedal. Could be a loose or torn hose, failing brake booster, failing aux vacuum pump.... no fault codes yet? Loosing any fluid?
no fauly codes or low fluid ,,

thanks man ill check those out . going for the cheap stuff first
 

·
Administrator
Joined
·
17,324 Posts
You have a 2016, which was the "cross-over" year where GM sold 2 versions of the 2016, the "Limited" which is a Gen8 holdover, and the new body style that is a true Gen9.

Which one is yours?
 

·
Registered
Joined
·
22 Posts
ok guys so im new on this forum , but ive been having issues with my brakes , it has a little over 80k miles, abs started acting up and the pedal would drop a little and make a thump sound coming from the driver side front wheel..and then just today brake pedal got hard as I was driving and would barely stop, any ideas?
Any chance the thump was on the other side of the driver;s side firewall, where the ABS pump/solenoids are normally located?

A hard brake pedal and not stopping suggests that the 3000 psi ABS pressure is somewhere it should not be...Given that and a soft pedal, and I would be looking for a leaky seal (or bad solenoid) first. While I lean toward do it yourself fixes, I would go to the dealer for this one. They have the proper diagnostic equipment and brakes are nothing to screw around with, if you are not certain what you are doing.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Any chance the thump was on the other side of the driver;s side firewall, where the ABS pump/solenoids are normally located?

A hard brake pedal and not stopping suggests that the 3000 psi ABS pressure is somewhere it should not be...Given that and a soft pedal, and I would be looking for a leaky seal (or bad solenoid) first. While I lean toward do it yourself fixes, I would go to the dealer for this one. They have the proper diagnostic equipment and brakes are nothing to screw around with, if you are not certain what you are doing.
Yes the thump is coming from the driver side firewall ..
 
1 - 7 of 7 Posts
Top