Chevrolet Malibu Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
My stabilitrak service light came on and check engine light also. My car has been idoling rough when I’m in drive stopped or speeding up.. I’m not sure what the problem is if anyone can help me I’d appreciate it
 

·
Super Moderator
Joined
·
4,577 Posts
I moved your thread to the Problems/Service issues section where it belongs and updated your title to be more relevant to your problem "2016 Chevy Malibu" isn't going to get you clicks and help.

Please provide your trim level and engine. Also, if you can get someone to read the engine fault code stored in the computer that would help.

Rules for posting in the service section are here:

 

·
Super Moderator
Joined
·
1,831 Posts
Does not compute. The 2016 Malibu LT can have a 1.5T or 2.0T. The 2016 Malibu Limited can have a 2.5L. Do you know if your car has a turbo? You can also take a pic of the car or engine and I'll tell you. These engine differences will affect advice or relevant bulletin suggestions so really need to know.
 

·
Super Moderator
Joined
·
1,831 Posts
Ok, then it must be the 2.5L 2016 Malibu Limited (a gen8 car). I will move this discussion/thread to the gen8 section so other fellow owners can help troubleshoot your issue.

One first step I recommend is taking the car to AutoZone or similar auto parts store and asking to have the codes read. Let us know what those codes are.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
The check engine light shut off now. I have a shop next to my house and no codes came up on it at all. He said it could be a sensor for the stabilitrak and a coil pack for the car idling weird
 

·
Super Moderator
Joined
·
1,831 Posts
How many miles on this car?
 

·
Administrator
Joined
·
16,881 Posts
I have a Gen7 2011 and get the "Service ESC" and "ESC Off" messages after turning the steering wheel the first time or two after starting the car. The CEL does not turn on and there are no codes for it that I can find.

On my car, it is probably the SAS - steering angle sensor.

You might want to have that shop or a dealer do a deep scan, deeper than Auto Zone or most any other car parts can/will scan for free.
 

·
Super Moderator
Joined
·
1,831 Posts
The engine power is reduced message has many possible causes. Are you actually speed limited or is it just a message? It can be fuel, a pedal sensor, steering angle sensor as DrivenDaily mentioned above can do that, dirty throttle body... Have the code read by your shop and things will (hopefully) be much more clear.
 

·
Super Moderator
Joined
·
4,577 Posts
If your car has the check engine and other warning lights on, you literally must have codes stored in the computer. We need to know what those are because your issues could be caused by 20 different things.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #14
Ok I’m going to have the codes read tomorrow. Thanks guys. I’ll get back to you.
I’ve read other stuff online that this happens all the time to a lot of other people and Chevy has no idea how to fix it?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #15
I had my shop plug the computer in and it’s a misfire and accelerator sensor. And I found out my car is the 1.5T
 

·
Super Moderator
Joined
·
1,831 Posts
Thread moved to the gen9 section being a 1.5T. The pedal sensor should be covered by warranty all the way to 150k or 10 years. As for the misfire, depends on the code and additional testing if P0300. At 55k plugs need inspection and again depending on the specific code a compression test may be necessary. Good luck.
 

·
Registered
Joined
·
2 Posts
My stabilitrak service light came on and check engine light also. My car has been idoling rough when I’m in drive stopped or speeding up.. I’m not sure what the problem is if anyone can help me I’d appreciate it
Same problem on my 2013 turbo 2.0. It was the coilpack. Misfire on 1 cylinder.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #18
Same problem on my 2013 turbo 2.0. It was the coilpack. Misfire on 1 cylinder.
Thank you. I appreciate it. I’m going to try that out when plugged into the computer it said misfire in cylinder one and two so I’m going to change those two and hope it’s good wish me luck.
 
1 - 18 of 18 Posts
Top