Chevrolet Malibu Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I have a 2016 Premier Malibu, love it except for one issue that lingered for over a year even after 2 visits to my local Chevrolet dealership.
The issue was the Parking Brake Warning light would come on 100 feet after driving, there was nothing that was affected however the Emergency Brake would not be able to be activated once the light went on. I have never used the emergency brake, so it wasn't really a concern EXCEPT I realized this also prevented the cruise control from being able to be used.
After 2 week long visits (for the car) the problem would still appear. So this year when I took it in for annual inspection I told Chevrolet we need to fix this once and for all. They replaced modules, traced shorts, reprogrammed and talked with GM engineering (so they say). What finally solved the bloody issue is replacing a wiring harness F-Harness 84308947.
I hope none of you run into this issue, but if you do hopefully this helps.
 

·
Registered
Joined
·
2 Posts
I have a 2016 Premier Malibu, love it except for one issue that lingered for over a year even after 2 visits to my local Chevrolet dealership.
The issue was the Parking Brake Warning light would come on 100 feet after driving, there was nothing that was affected however the Emergency Brake would not be able to be activated once the light went on. I have never used the emergency brake, so it wasn't really a concern EXCEPT I realized this also prevented the cruise control from being able to be used.
After 2 week long visits (for the car) the problem would still appear. So this year when I took it in for annual inspection I told Chevrolet we need to fix this once and for all. They replaced modules, traced shorts, reprogrammed and talked with GM engineering (so they say). What finally solved the bloody issue is replacing a wiring harness F-Harness 84308947.
I hope none of you run into this issue, but if you do hopefully this helps.
I think I am dealing with the exact same issue.. can you tell me if you were stil under bumper to bumper warranty or you had to pay out of pocket, because I’m out of b to b and the dealer wants $145 just to look at the “electrical” problem. Thanks and I look forward to hearing from you cause the fact that this is not letting me use cruise control is unbelievably frustrating lol
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top