Chevrolet Malibu Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
So my 2019 chevy mailbu LT hit 44k miles this morning and this car has always been quite speedy for what it is LOL. i noticed this morning that i have little to no power before 20mph! i tested this countless times and i will have the petal fully down and my car will slowly go to 20 then floor it..... what is the issue? i have a warrenty on my car so im going to the dealership later today!):
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #2 ·
Update-I took the car to the dealership and this morning for the appointment and yet to hear anything but i do have a video of said issue. its like the turbo doesnt engage until 3500rpm’s or something is restricting it. or is this a transmission issue? i have never ran into this issue before and it was 2x worse taking it to the dealer this morning (didnt get a video of it. was focused on getting to dealer safely cuz driving from a complete stop is so slow) no engine light still and im waiting to hear from the dealer. how do i add a video to this lol?
 

·
Super Moderator
2016 Malibu 1LT 1.5T/6-speed 6T40
Joined
·
4,230 Posts
I hope the dealer figures it out. It could be many things, hard to say from here so let them go through their full process. If they find nothing, ask if they checked this bulletin for false knock detection, it's just an ECM update: https://static.nhtsa.gov/odi/tsbs/2019/MC-10166651-9999.pdf
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #7 ·
Have they provided you with any updates? My 2019 RS started doing the exact same thing today. It’s actually quite dangerous because the car will not accelerate in a quick enough time, if needed.
The dealer fixed the issue and i wanted to post pictures of the paperwork but i sadly picked the car up after hours and had my other grab the keys and she didnt grab paperwork🤦🏻‍♂️ they told me they reprogramed the ecu and that solved my issue!:)
 

·
Registered
Joined
·
3 Posts
The dealer fixed the issue and i wanted to post pictures of the paperwork but i sadly picked the car up after hours and had my other grab the keys and she didnt grab paperwork🤦🏻‍♂️ they told me they reprogramed the ecu and that solved my issue!:)
Sorry for the late reply. Turns out mine has a different serious issue and now they’re replacing the pistons. The acceleration delay was due to misfiring from blown piston rings. The pistons are on back order and they don’t know when they’ll be in.
They put me in a 2021 loaner, so it’s not bad, but that’s the story on mine.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #9 ·
Sorry for the late reply. Turns out mine has a different serious issue and now they’re replacing the pistons. The acceleration delay was due to misfiring from blown piston rings. The pistons are on back order and they don’t know when they’ll be in.
They put me in a 2021 loaner, so it’s not bad, but that’s the story on mine.
wow thats sad but i hope they get it fixed for you. i wanted the rs at the time i bought mine but got the LT instead. good luck my friend. the 2021 has stock LED headlights to what i have read. is so correct?
 

·
Super Moderator
2016 Malibu 1LT 1.5T/6-speed 6T40
Joined
·
4,230 Posts
The dealer fixed the issue and i wanted to post pictures of the paperwork but i sadly picked the car up after hours and had my other grab the keys and she didnt grab paperwork🤦🏻‍♂️ they told me they reprogramed the ecu and that solved my issue!:)
I missed this post - glad it got bumped. Great to read it was just the ECM update. Car has been fine since I take it?

@kmm_satx Bummer your issue turned out to be something different. I think your report is the 2nd report of busted piston(s) on a 2019. That can and will continue to happen sometimes. If you want to explore ways to reduce risk in the future let us know.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #11 ·
I missed this post - glad it got bumped. Great to read it was just the ECM update. Car has been fine since I take it?

@kmm_satx Bummer your issue turned out to be something different. I think your report is the 2nd report of busted piston(s) on a 2019. That can and will continue to happen sometimes. If you want to explore ways to reduce risk in the future let us know.
yeah i havnt had a issue since. mailbu has gone 5k miles since the issue🙂
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top