Chevrolet Malibu Forums banner

1 - 3 of 3 Posts

·
Registered
2017 Chevrolet Malibu LT 1.5 / 1994 Chevrolet Caprice Classic 4.3 L99 v8
Joined
·
2 Posts
Discussion Starter #1
Hey all, hopefully looking for some help with my Malibu. I listen to music 24/7 and pretty loud. I have the 8" MyLink without Bose just the 6 speakers stock. When I bought the car 3 years ago I had an auto shop upgrade and add two kicker 6x9s in the rear deck and installed a 12' Sub. The only modifications to the stock stereo I can see they made would be installing an LOC at the stock amp behind the trunk liner.

Last night I went out to drive my car and noticed my stereo was lifeless with a dead screen, no backup camera, and only could hear a very faint door chime. The car operated and drove like normal. I could not get the radio to function at all, even hitting the onstar button did nothing except cause the onstar light to flash indicating the system was active (there is an active subscription). Today when I went out to the car the door chime was back to normal and I could turn the radio on by just clicking the power button when the car was powered off (not pushing the start button at all). All radio functions worked, sirius worked, BT, everything. The second I click the start button for the engine/car to start the engine/car the radio goes dead and becomes lifeless. If I shut the engine off and car, open the door, wait a minute for the screen in the gauge cluster to shut off I can then push just the power button on the radio and it powers on like normal and pairs to my phone like normal. I can repeat this process with no luck of the radio staying on when I start the car/engine.

Any help would be greatly appreciated, my bu does not feel like my bu without any music for sure! lol

Not under warranty, 60k miles.
 

·
Registered
2017 Chevrolet Malibu LT 1.5 / 1994 Chevrolet Caprice Classic 4.3 L99 v8
Joined
·
2 Posts
Discussion Starter #2
Update -- Onstar did a "radio reset" and nothing happened. I seem to be able to keep the radio on as long as I start the car with the chevy app on my phone and as long as the car doesn't start/stop the radio stays on. Then I noticed about three days ago the radio was 100% lifeless. I go out to drive somewhere today and it powered on with the engine playing music and everything like normal, I could stop at red lights the engine start/stop like normal and the radio would stay on. I get home, shut the car off and open/close my driver door, start the engine and the radio was again lifeless. I guess my only option is to take it to the dealership and see if they can run a diagnostics on the system, and see if it needs to be fully replaced or not.
 

·
Super Moderator
2016 Malibu 1LT 1.5T
Joined
·
2,686 Posts
I don't read much about total failure of the 8" MyLink leading to replacement which makes me suspect something loose. Odds of that are a bit higher if wiring has been spliced to add speakers. Other than checking connections and harnesses for tightness there isn't much to do with an intermittent issue like this. I'd also remove any USB connections and Bluetooth connections to see if it persists. Hopefully the dealer can sort it out.
 
1 - 3 of 3 Posts
Top