Chevrolet Malibu Forums banner

Android Auto suddenly not working

6313 Views 7 Replies 3 Participants Last post by  A_reid93
I have a 2016 Malibu LT 1.5T with the 7” my link infotainment and using a Samsung galaxy Note 8. I have been using android auto for months since I got the car with no issues, but suddenly one day I plug my phone in and I get the prompt to switch to android auto but it never actually pops up on the cars screen and my phone screen goes black for a second as if it’s going to switch but then goes back to the home screen and nothing else happens. I haven’t gotten a android auto app update, no phone update, and no setting changes to the car. I even tried another android phone and I get the same result. The only time I get it to mirror on the cars screen is by deleting the android auto app, plugging the phone into the cars USB port, and then following the steps to setup android auto as if it’s the first time using it. Even when doing that android auto still doesn’t perform properly and is very buggy. Anyone run into this issue or found a fix?
Not open for further replies.
1 - 8 of 8 Posts
I have pretty much the same car as you. 2016 LT w/ 7" MyLink. Late last week I plugged in my phone and tried Android Auto - failed to launch. It has been working fine for a long time - especially well since the overhaul beta that is now official. I had been ignoring it but seeing your post I decided to sort it out. Tried again this morning and on connect it still failed to launch. I cleared the data and cache via settings/apps and still failed.

I try not to go small when fixing things like this and go all out:

1) unpaired/deleted my phone from MyLink and disconnected USB cable
2) uninstalled Android Auto (I was on the latest version 5.0.500223)
3) restarted phone
4) Bluetooth paired to car
5) Plugged in USB cable to car
6) MyLink detected AA capable phone
7) downloaded AA automatically following prompts
8) started AA, granting all permissions
9) launched map, tested voice, tested fine

I have since started and restarted the car, tested fine. Restarted phone and car again, all auto launching fine.

I am still on AA 5.0.500223 and running Android 9 with Dec 2019 security patches. Galaxy S9.
See less See more
  • Like
Reactions: 1
I'll try that later and see if that works. I'll give you an update. Thanks
Update: I did try those steps form above and as usual it works when I first plug it in and setup but once I leave the car and come back and try plugging it in it still doesn't launch AA. Not sure what else to do now.
What Android and AA version? Has your MyLink ever received any updates?
Samsung Galaxy note 8. Same version you have so the latest version. I've only had the car for 7 months and I've never gotten my link updated so I'm not sure if it's been updated before. That's going to be my next step.
I was having the same problem with my Galaxy 8+. I replaced the generic USB cable with a Samsung cable and all works good now.
I was having the same problem with my Galaxy 8+. I replaced the generic USB cable with a Samsung cable and all works good now.
Yea that was one of the first things I did. I might just go to a dealer and see if there is an update available for my link
1 - 8 of 8 Posts
Not open for further replies.