Chevrolet Malibu Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1 (Edited)
First off I understand the general consensus is A/S bad, must disable. I'd rather keep it and keep it functioning.

So I financed my Malibu a year ago. The Auto Stop functioned for a week then hasn't worked since. Until about 2 weeks ago, it randomly started working again and functioned fine until the other day where it has once again vanished. I say vanished as it hasn't thrown any codes.

I am wondering what all I can check or do to troubleshoot it so I can get it functioning again. I have had both batteries tested and orielly says both are good. Neither was removed from the vehicle or disconnected and not sure if that would affect the results.
If I could also get the parameters A/S checks for before it allows an engine shut down that would be much appreciated.

Thank you for any help. I have tried googling it but all I can find is people complaining about it and how to disable it or atleast try to.

Edit: It's a 2016 Malibu LS Limited
 

·
Premium Member
Joined
·
1,983 Posts
Full scan of all 4 code families is step one not just the P codes.
Year of your car is helpful also.
 

·
Super Moderator
2017 SS Sedan 6.2L
Joined
·
5,273 Posts
There were issues with auto stop on the early years, like your 2016. I believe there is a dealership reprogram TSB for it, I'm not sure if you will have to pay for it since you're out of warranty, but it wouldn't be expensive.
 
1 - 4 of 4 Posts
Top