Chevrolet Malibu Forums banner

Status
Not open for further replies.
1 - 15 of 15 Posts

·
Registered
Joined
·
569 Posts
Discussion Starter #1
Well when I first bought my malibu The Drivers side A-pillar had popped loose breaking a clip.. How or why I dont know but it caused the cars check engine light to come. The dealer ordered a new part and it was put in and all is well..

Today I drove to work as always and even went out for lunch.. No issues.

I got in the car after work and turned the key, All electrical came on but the car would not start, No turn over or anything.. Just nothing. I tried a few more times still nothing. I took the key out and shut and locked all the doors and reunlocked and got back in and it cranked up this time. Now I have a check engine light on.. I started to head out of the parking lot and hit my blue on star button because I remember hearing they can run diagnostics.

Well while they had me on hold I turned on the busy street and noticed the car was not changing gears. Busy Street and not changing gears is bad.. I dropped it into Manual and the DIC did not change and i stayed stuck in first gear trying not to over rev the engine.. I finally found a place to pull over and the on star rep told me that there is a communication problem is what there seeing.. I turned the car off and let it sit for a moment and tried again and we were able to be on our way.

The on star rep said there system advises to get it to the dealer as soon as possible and to call back in the morning and they would transmit there findings to the local dealer so I can take it in.

I hope this is not a sign of things to come with this car.... :confused:
 

·
Registered
Joined
·
701 Posts
Malibudragon - WOW - I hope everything is okay.

Regarding your A Pillar and a check engine light, I suspect it is to do with the side airbags, if that A Pillar is popped out it may cause the air bag system to throw a code advising that you need to be serviced. Just a thought.

Regarding your communication / tranny issue....sound definately like a sensor of some sort is not communicating properly with the car.

Like they say if something is going to go wrong it will happen in the beginning. Take me for instance, had a purge valve sensor go with only 2500 km's on it. No worries, these things do happen. Better to have an iffy part go now, instead of outside warranty.
 

·
Registered
Joined
·
569 Posts
Discussion Starter #3
Very True..

I just dropped off the malibu at the dealer and they gave me a ride to work.. HE said he was going to call me once they know something and said they will give me a loaner if it needs to stay overnight.
 

·
Registered
Joined
·
701 Posts
Good to hear - Hopefully it is as simple as a sensor.....although are cars are mechanical, they are also very electronic and it could be a simple as a tranny sensor having gone bad. Let us know how you make out.
 

·
Registered
Joined
·
569 Posts
Discussion Starter #5
They are keeping the car overnight and have not been able to duplicate the issue. They want to test it in the morning again before calling it a fluke. The code triggered was a "Communications Problem" and that's all they know. No bulletins or anything in the system.. They gave me a Chevy lumina to drive
 

·
Registered
Joined
·
749 Posts
Ahh everything about this thread sucks! Hope all goes well!! The loaner is nothing special but at least they were good enough to offer one.. our local dealership doesn't even have loaners available they need to reimburse for rentals if it needs to stay overnight :-(
 

·
Registered
Joined
·
569 Posts
Discussion Starter #7
Ahh everything about this thread sucks! Hope all goes well!! The loaner is nothing special but at least they were good enough to offer one.. our local dealership doesn't even have loaners available they need to reimburse for rentals if it needs to stay overnight :-(
Yeah ours said they would do that after one day if it needed to stay longer than a day.
 

·
Premium Member
Joined
·
915 Posts
Ahh everything about this thread sucks! Hope all goes well!! The loaner is nothing special but at least they were good enough to offer one.. our local dealership doesn't even have loaners available they need to reimburse for rentals if it needs to stay overnight :-(
Very few do, but the daily rental coverage is the typical, if kept overnight.

This is really bizarre, but it sounds like some kind of a computer issue. My G6 that's being repurchased has had a number of weird glitches that I still think are computer related, from warning messages coming on that--in live time--Onstar can read nothing back from when they should be able to, let alone the dealer later on, to bizarre variations in the running condition that vary frequently and can never be traced down. Kind of like yours.

My only advice is that, if they can't find anything, when you get the car back watch it closely and start taking notes on anything weird that happens in detail and when, and if such a thing happens again immediately connect to Onstar and have them run diagnostics to see if anything is reading back. Further, and not that this is a lemon case, etc. as mine, but live video is priceless. My digital camera takes terrific video and is small, so once the issues started with my G6 I started taking it in the car daily and recorded a month's worth of "issues" easily for the dealer and GM to see--helped greatly.

Best of luck. I know what it's like when such craziness escalates to the point of no return, so hopefully this is either a one time thing or something that can eventually be tracked down by the dealer without too much undue grief on your part.
 

·
Registered
Joined
·
569 Posts
Discussion Starter #9
Thats a good idea with the camera and all..I will put a small note pad and pen in the car to just in case. I stopped and put a couple dollars worth of gas in the loaner car since it was dead empty when I got it. Didn't think I would make it to work so I didn't chance it,

The service guy told me to call him about 10a to see if there is any updates but as of yesterday evening the service tech has found nothing wrong other than the code tripped "Connection Problem". Said he went on a couple test drives and everything was working ok so hopefully just a fluke
 

·
Registered
Joined
·
569 Posts
Discussion Starter #10
Update:

Just talked with the tech and they found that the battery was messed up, he called it a "Weak battery" and is swapping it out now.

he said to give him a couple hours and it would be ready to be picked up :D
 

·
Registered
Joined
·
126 Posts
Update:

Just talked with the tech and they found that the battery was messed up, he called it a "Weak battery" and is swapping it out now.

he said to give him a couple hours and it would be ready to be picked up :D
Glad to hear that you had me worried!
 

·
Registered
Joined
·
569 Posts
Discussion Starter #12
Just picked up the malibu and drove it back to work.. Had to run some errands and put some gas in it and all seems well.. I lost all my radio settings and the seats were all moved around so now I've got to get all that set again lol..

Im so glad it was nothing serious!
 

·
Premium Member
Joined
·
915 Posts
That's weird, as the battery really shouldn't be doing anything when you're running, the rest of the electrical system should be, but hopefully nothing further is erratic. When cars are so complex, like anything, the littlest glitches can really become headaches.

Here's to hoping the shiny red 'Bu is A-ok from here on out.
 
1 - 15 of 15 Posts
Status
Not open for further replies.
Top