Chevrolet Malibu Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello everyone.

I own a 2010 Chevrolet Malibu 3.5LT. About a few months ago, I noticed my engine temperature was going up a little bit when I drive fast and sometimes when standing still (whenever the air intake is low).

When this happens, I go outside to open the hood and I take a look at the intake fans. Most of time, both fans are working but at very low speed where they should be at the top speed because the engine needs the air.

In order to solve it, I turn on the AC and then both fans kick into the highest speed setting and the temperature goes back to normal (90•C).

I suspect it’s the thermostat but I’m not sure. Using a quite expensive code reader, no DTCs were found but the code reader can’t access the AIR or CAT modules because the car doesn’t support it so I wouldn’t know.

Has anyone experienced a similar issue or can point me in the right direction?

thank you.
 

·
Administrator
2011 Malibu LTZ 3.6L V6 Red Jewel Tintcoat
Joined
·
17,649 Posts
Could you double-check your engine size, please? The 3.5L was offered in earlier years but may have still been available in 2010. It would be a pushrod engine. The 3.6L is a DOHC engine that is quite a bit different.

You can pop the hood and check the engine cover. If it says VVT then it'll also say 3.6L. If not, then the emissions sticker will reveal the engine size regardless of any engine decals.

68452


Also, please include whether you have the 4-speed or 6-speed transmission. That may help others to help you as well.

---------

Now, on to offering some input.

The radiator fans are designed to run at 2 speeds, lower when less cooling is needed, and higher when more is needed or when AC is turned on.

With that expensive reader, pull up the actual coolant temps and read them, possibly even putting them on a graph as you drive, and then later review them for any signs of issues.

My 2011 3.6L temp runs right about the middle of the gauge, but you have to understand that the gauges are not directly driven by input from the sensors. The BCM receives those inputs and then tells the IPC where to point the needles. It interprets them to some degree to provide useful data to the driver. If your engine is overheating, believe me, you'll get a warning and a light. If it gets too hot, it'll put you in limp mode to help preserve the engine. It's made of aluminum and doesn't handle being overheated very well at all, not like iron can.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Could you double-check your engine size, please? The 3.5L was offered in earlier years but may have still been available in 2010. It would be a pushrod engine. The 3.6L is a DOHC engine that is quite a bit different.
Thank you so much for the fast reply!

As for the engine size - it is for sure a 3.5L, says so everywhere including the engine cover, decals and registration. I know for sure my model is one of the last 3.5 of 2010's in my country (Israel).
It is also a 4-speed transmission (unfortunately, feels like a 6-speed would suit her much better. I wonder if anyone ever changed that?).

As for the temperature - I understand the gauge reading can be a bit off sometime so I never count on that. When the car feels like it needs air and it's overheating (again, not overheating too much for it to pop up an error on the dash or limp mode), I try on the A/C and then the fans go to the fast speed setting and TONS of hot air blows out of the engine - proving me that it needed that air boost.

I will try your approach and report with results as soon as I can and even upload the graph here.

Do you think it might have something to do with the thermostat, maybe? Or is there any direction I can look into? We're getting closer to summer days and I really don't want this heavy load on the engine in the hot days.
 

·
Administrator
2011 Malibu LTZ 3.6L V6 Red Jewel Tintcoat
Joined
·
17,649 Posts
Thanks for confirming that!

It could easily be the t-stat.

Last year in April, my 3.6L started overheating, but I thought it was just a bad sensor since it didn't exhibit any other issues. I changed the sensor and it kept giving me the message, then it went into limp mode again. I finally had to park it and replace the t-stat, and I elected to also replace the water pump, all hoses, and coolant. While I was at it I cleaned the recovery bottle inside and out.

To confirm I got the source of the trouble I boiled the old and new t-stats and only the new one opened. The old one failed closed and stayed that way. Most of them fail open.

What kind of maintenance has been done on the cooling system?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
I haven’t done any maintenance to it yet, I’m only starting to mess with it now. Unfortunately, in Israel, the maintenance level is very low especially in such old cars and it’s hard to find someone reliable.

Can you provide me with the t-stat part number for my car and tell me if replacement is easy? I’ve seen some YouTube videos where you just have to take 2 10mm nuts that surround the metal plate and inside is the t-stat.

Thank you again.
 

·
Premium Member
Joined
·
1,412 Posts
The best online resource for parts is rockauto.com. . They list part numbers including factory part numbers from many manufacturer's so you have a choice.
 
1 - 6 of 6 Posts
Top