Chevrolet Malibu Forums banner

21 - 30 of 30 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #22
There is something wrong with my car .im using torque app to measure my engine load when i press the gas goes to 19,11 20 sometimes 40 and sometimes 50 and absulote load sometimes goes to 60 my fuel rail pressure also low doesnt pass 4500 what could be the problem ?so i did little test, when i take off my maf and iat sensors and try to start the car it dies which indicates that map sensor doesnt send correct data? when i use cruise control its probably bypasses the map sensor and other sensors data and the car drives well also fuel rail pressure in cruise control goes to 19000 easily when i press and absulote load goes to 80 90 100 depending how much i press + but the engine load that map sends stay low
 

Attachments

·
Premium Member
Joined
·
1,542 Posts
Could be a bad, intermittent throttle pedal assy. that is not working right at light throttle . Cruise does not use the pedal assy. to maintain speed, ECM works throttle body directly.
Disconnecting the MAF will cause it not to run and it's always being used by the ECM if on cruise or not. Normal for engine to stall out with MAF disconnected.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #26
Could be a bad, intermittent throttle pedal assy. that is not working right at light throttle . Cruise does not use the pedal assy. to maintain speed, ECM works throttle body directly.
Disconnecting the MAF will cause it not to run and it's always being used by the ECM if on cruise or not. Normal for engine to stall out with MAF disconnected.
Still didnt help it looks like that the cruise control bypasses map sensors data is that possible?
 

·
Premium Member
Joined
·
1,542 Posts
No
MAF sensor measure the amount of air and it's temperature entering the engine. It is used to run engine fuel management no matter what driving mode you are using.
A scan of not only the P codes is needed but the other 3 need to be read which are C , B and U to get a complete picture of the cars systems. A issue in one of the others may not show up in the P codes.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #28
The car feels undrivable its like dragging a extra car behind me each small thing impacts preformance from ac to another passanger not fault codes both ecm, bcm, and transsmision control module.Ive tried almost everything changed spark plugs, catalytic converter, all sensors gas pedal .. even turbo solenoids but my car keeps getting sluggish as soon as i slow down or go into heavy traffic it 90% of the time will become extremely slow even if i press full gas the rmp goes up but speed wont catch up it feels like car slows down as soon as i leave the gas pedal and when pressing break it also goes to that limp mode .it becomes heavy when road is clear its drivable at high speeds this problem may suddenly disappear and come back while driving doesnt metter if engine is cold or hot but rarely the car drives very good with ac on, and extra passangers it feels very smooth and powerful
 

·
Registered
Joined
·
32 Posts
I'm no mechanic - unless I'm in my driveway. But you might want to take a look at your throttle body and see if it has accumulated a bunch of goop in the opening and on the flapper. These cars a fly-by-wire and they have a learning process. If over time you have a build up, your car has been adjusting for that and you may be beyond some tipping point. It's worth a peek just to gauge condition. If it looks like some flavor of this image here, it's time for a clean up. However, use caution. I've seen lots of posts here about bad results if you spray cleaner directly into the throttle body. You want to do some homework on best way to accomplish this cleaning. Also I've seen post about post-cleaning bad performance because the learning function has learned over time and when you clean it, the learn function has no idea you cleaned it and all the adjustments the learn function has made over the years to compensate for buildup will still be in place. I think there is a procedure to re-learn without a meter, but don't recall specifically so you'll need to look that up or get a GM specific meter which has those learn functions built in (I use the Foxwell 510 elite with GM package installed). And I can't stress enough to do some research on how to properly clean the throttle body - I've seen discussions here and elsewhere about improper cleaning causing an issue.

69144
 

·
Registered
Joined
·
35 Posts
Discussion Starter #30
Ive changed the thorttle body nothing has changed car drove well for a while and again in high traffic became slow sluggish

Can it be ecm ?
 
21 - 30 of 30 Posts
Top