Chevrolet Malibu Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hi,

My 2004 Classic with 4 cyl ecotech has code MIL on and code P0455. I cleared it but it came back on within a day with the same code. Gas cap was on tight and I don't have a diagnostic tool so I'm limited with the testing I can do.

Obviously I don't want to replace unnecessary parts. As far as can tell they aren't renowned for a particular failure.

My plan is to replace gas cap and see if that fixes it, then change the bypass valve, and so on...

Does someone have a better plan to suggest or some kind of test that doesn't require a diag tool?

Thanks in advance.
DB
 

·
Registered
Joined
·
13 Posts
Discussion Starter #2
I know, it's been over 7 months and MIL still on. Replaced the cap, that did nothing and P0455 still cumming back. I've come across some post were the canister was flooded, is that the next step to check?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
Removed and inspected canister and seems good. I plugged up 2/3 holes and blew in the third, no leaks. Next would be vent solenoid? Parts store sell the replacement for $35-70 for this FishePrice gizmo. Hardly seems worth that much.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
vent solenoid checked out ok, 12v got it to close hold pressure. Purge valve under the hood?
 

·
Administrator
2011 Malibu LTZ 3.6L V6 Red Jewel Tintcoat
Joined
·
18,147 Posts
I've been reading every post and it looks like you're nearly done. I hope so!
 

·
Registered
Joined
·
274 Posts
sometimes the fault is in connections somewhere, i had the same code before because of one of the purge valve wires break inside the insulation close to the connector plug, may be in yours bad contact more than true leak.
 
  • Like
Reactions: Darthz

·
Registered
Joined
·
483 Posts
Agreed on the wiring. Heck my BCM harnes is what was causeing my brake lights to come on..... was too tight..... the GM recall on the issue....... they put a dam zip tie on the plug to keep it tight lmao
 

·
Registered
Joined
·
13 Posts
Discussion Starter #8
That p0455 keeps coming back. Both purge and vent solenoids have +12v. I pressurized the system with vent plugged and didn’t find any obvious leaks. Although a “gross/large” leak doesn’t need to be that big after all. I did manage to see the gas tank swell up a bit. Might be as electrical As some suggested. It needs to get emission done next month, wish I could get a bidirectional tester without dropping over $1-3k.
 

·
Registered
Joined
·
483 Posts
I too have this code now.....but my gas guage is pooched....exhaust is toasted....and my new gas cap.....well i keep getting a check gas cap warning.....but its random

Curious how you make out with this
 

·
Registered
Joined
·
13 Posts
Discussion Starter #10
Ok, well I'm getting 0.2v at the green wire of the TFP sensor.

According to this guy I should have 1.5v (ignition on) on GM.

Not having fun... :(
69382
 
1 - 10 of 10 Posts
Top