Chevrolet Malibu Forums banner
1 - 15 of 15 Posts

· Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
The other day got in the car started and left the house got 1/4 mile down the road, car dies, was able to restart and get 1/8 mile back before dies again, cranked and cranked the car started and die several times. finally get it home and in the drive way noticed the temp and fuel gauges are not working when the key is on. At times they will work and then stop. Can start the car and it runs for seconds or minutes then dies all while running the fuel and temp are randomly working. Sometimes the car starts and goes high idle and stays there and dies or times it starts and is fine. At times you can hear the fuel pump kick in and start and shut off.
Hoping for a scan tool early this week

Had similar problem last year here is what was changed:
-Battery
-Both the negative and positive battery cables (replaced both with AC Delco)
-Key switch (again AC Delco)
the fuel pump has been replaced a few years ago
Where should I start checking?
 

· Administrator
2011 Malibu LTZ 3.6L V6 Red Jewel Tintcoat
Joined
·
21,153 Posts
Please share the year, engine, trans, trim level so others can offer more specific assistance.
 

· Registered
Joined
·
13 Posts
Discussion Starter · #3 ·
The other day got in the car started and left the house got 1/4 mile down the road, car dies, was able to restart and get 1/8 mile back before dies again, cranked and cranked the car started and die several times. finally get it home and in the drive way noticed the temp and fuel gauges are not working when the key is on. At times they will work and then stop. Can start the car and it runs for seconds or minutes then dies all while running the fuel and temp are randomly working. Sometimes the car starts and goes high idle and stays there and dies or times it starts and is fine. At times you can hear the fuel pump kick in and start and shut off.
Hoping for a scan tool early this week

Had similar problem last year here is what was changed:
-Battery
-Both the negative and positive battery cables (replaced both with AC Delco)
-Key switch (again AC Delco)
the fuel pump has been replaced a few years ago
Where should I start checking?
IF it helps 2003 LS with a 3100 engine, 147,000 miles
 

· Registered
Joined
·
1,079 Posts
If the temp guage is screwed....or at least telling the ecm or whatever its too hot.... pretty sure it will shut dpwn the car. But problem with my theory..... should be two twmp sensors one in one of the cylinder heads (for the guage itself) and the other possibly by the water pump ( ecm reads)

Are your guages always ....not working correctly? Or only during these stop running times?
 

· Registered
Joined
·
1,079 Posts
I wold start peaking around wiring possibly. .. maybe locate a wiring diagram.... see if there is a shared harness. ...possible multi plug ? I would start there myself...without a definitive cause....maybe somone has more insight
 

· Registered
Joined
·
13 Posts
Discussion Starter · #6 ·
If the temp guage is screwed....or at least telling the ecm or whatever its too hot.... pretty sure it will shut dpwn the car. But problem with my theory..... should be two twmp sensors one in one of the cylinder heads (for the guage itself) and the other possibly by the water pump ( ecm reads)

Are your guages always ....not working correctly? Or only during these stop running times?
sometimes they are not working at all they are laying down like the car is off, if you leave the key on the gauges will jump around and fall. you can also hear the relay for the fuel pump going in and out.
 

· Registered
Joined
·
1,079 Posts
What about lights dimming? When this stuff happens ...do your dash lights or even headlights do any sprt of dimming?just wondering about somesort of power interruption for the whole car vs pmc issues
 

· Registered
Joined
·
13 Posts
Discussion Starter · #8 ·
I have been doing this in the day hard to tell if the lights are dimming, today my dad brought over a scan tool and it had 20 some codes under the PCM everything from fuel sender voltage to engine sensors out of voltage specs. with the key on was able to watch the 02 senors voltage jump around at times the intake air was almost 200 degrees. Almost think its the PCM.
 

· Administrator
2011 Malibu LTZ 3.6L V6 Red Jewel Tintcoat
Joined
·
21,153 Posts
Have the battery checked very thoroughly.
 

· Registered
Joined
·
1,079 Posts
Dont just act on my suggestion here.... but after reading them wierd symptoms i am wondering about pcm.


But to add.... when myalterntor died in my z24 while driving. ..... the guages all died first. So I would check the batteryand alternator out first lile Driven Daily said
 

· Registered
Joined
·
13 Posts
Discussion Starter · #12 ·
Dont just act on my suggestion here.... but after reading them wierd symptoms i am wondering about pcm.


But to add.... when myalterntor died in my z24 while driving. ..... the guages all died first. So I would check the batteryand alternator out first lile Driven Daily said
I have been thinking the same, they are not that much to order a programmed one. I just got done checking my grounds had someone watch the gauges while I did the "wiggle test" gently. I looked at a schematic and the fuel pump, gauges and the air idle control run off the PCM.
 

· Registered
Joined
·
13 Posts
Discussion Starter · #14 ·
Dam.... sucks all tuese issues eh? Well if you go ahead with it...let us know how ya make out
I am going to troubleshoot the grounding, before ordering. Today I got the scan tool and it cannot scan the PCM says no "communication." so I would like to make sure the ground on the engine is not corroded before ordering or going farther.
 

· Registered
Joined
·
1,079 Posts
Man, i would be leaning towards that dang pcm after seeing that....but again it would be a kneejerk reaction.....hopefully you find its just a bad ground
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top