Chevrolet Malibu Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 2011 model. Mine went into reduced power mode after idling for an extended amount of time. I shut it off and let it sit for about 30-45 mins and it started up fine. Drove fine for a few days and did it again while driving. It happened one other time so I took it to have the code read. Showed both cam shaft position sensors. I replaced them myself. It happened again so I took to a shop and he couldn’t diagnose it and when I got it back it was even worse so I took it elsewhere and had the throttle body cleaned, plugs and wires replaced. Got it back, still does it. Took it to another shop and they said ecm was bad. I replaced it and they relearned the throttle body. Got it back and it did it again. I’m at a loss here. I’ve put in over 1000$ worth of parts and labor into this car and still can’t drive it. I’m wondering if the cat is bad. Would that cause it to go into limp mode like this? Ever since I bought it I have noticed that when I start it and am at idle it smells like exhaust inside the vehicle if I have my air on the outside cycle rather than cycling through the vehicle. Please help!
 

·
Administrator
2011 Malibu LTZ 3.6L V6 Red Jewel Tintcoat
Joined
·
20,039 Posts

·
Registered
Joined
·
1 Posts
I have a 2014 chevy equinox it start up n run but it really won’t idle it a rattling noise under hood the reduced engine signal came on it shuts off sometimes but does drive but doesn’t seem like to far I was told my timing chain but I wanted another opinion
 

·
Premium Member
Joined
·
2,704 Posts
It's hard to diagnose that over the web without checking failure codes and actually listening to it.

I have a 2014 chevy equinox it start up n run but it really won’t idle it a rattling noise under hood the reduced engine signal came on it shuts off sometimes but does drive but doesn’t seem like to far I was told my timing chain but I wanted another opinion
 
1 - 5 of 5 Posts
Top