Chevrolet Malibu Forums banner

Status
Not open for further replies.
221 - 226 of 226 Posts

·
Registered
Joined
·
8 Posts
I'd like to see posters list the mileage that the valves are failing at.
It would let others know what time / mileage frame this is occurring.
TIA
Mine failed at 95,809. Good thought.

Thank you for sharing the information on this post. It is nice to finally get the part after so many months. I also ordered the part from Valve 19419980 | GMPartOnline last week and I received the part today. I ordered the gasket with it as well. I paid $128.06 altogether with shipping. I plan to get it fixed soon.
It is a very easy change. Good luck!
 

·
Registered
Joined
·
2 Posts
All, I’ve got an impala with the same 2.5 and faulty valve. Have a question regarding the old one breaking and leaving parts stuck in the camshaft cover. Is there a potential for catastrophic engine damage or will the new valve still not function correctly if this happens and the cover is not replaced? Thanks for your help.
 

·
Premium Member
Joined
·
1,811 Posts
All, I’ve got an impala with the same 2.5 and faulty valve. Have a question regarding the old one breaking and leaving parts stuck in the camshaft cover. Is there a potential for catastrophic engine damage or will the new valve still not function correctly if this happens and the cover is not replaced? Thanks for your help.
Parts plugging the passages will plug oil flow and still make new valve act like the old one.
See the earlier post with the bulletin with pics , old valve needs to be inspected when first removed from engine.
 

·
Registered
Joined
·
8 Posts
All, I’ve got an impala with the same 2.5 and faulty valve. Have a question regarding the old one breaking and leaving parts stuck in the camshaft cover. Is there a potential for catastrophic engine damage or will the new valve still not function correctly if this happens and the cover is not replaced? Thanks for your help.
Did you find the parts to have fallen out of the old valve?

If so, unfortunately the cover will need to be removed and replaced to fix the issue.
 

·
Registered
Joined
·
2 Posts
My old valve did fly apart. I believe it only happened once I removed the part. I retrieved everything but one of the plungers. I haven’t looked for it today but I believe it went flying from the spring pressure when I removed it instead of into the cam cover while the engine was running. I’m not sure the cam cover is something I want to tackle so I’m thinking about installing the new valve even if I can’t locate the missing piece. If the code clears and stays clear all will be well but if it comes back I will probably take to a mechanic. I just wanted confirmation that it shouldn’t destroy the valve train if you drive it with a possible piece blocking an oil passage. Thanks for your help!
 
221 - 226 of 226 Posts
Status
Not open for further replies.
Top