Chevrolet Malibu Forums banner

1 - 20 of 30 Posts

·
Registered
Joined
·
191 Posts
Discussion Starter · #1 ·
2011 malibu 2.4 liter flex fuel 6 speed automatic. I disconnected the battery terminals the day before I had the fluid changed in transmission. Now I'm getting shift flares randomly. Today and yesterday of this week and Thursday Friday of last week. I got ahold of dealer and told them what I stated above and they said it could take a few dozen drive cycles to relearn how I drive with the engine and transmission. I asked so it could be a few weeks and they said yes. Said if it gets worse or doesn't get better to bring it in. It did it before the fluid change but remembered I disconnected the battery terminals to clean them about a month ago. How long do you think it takes for a car to learn how you drive?
 

·
Registered
Joined
·
191 Posts
Discussion Starter · #2 ·
I disconnected again because I forgot to check the bottom of the terminals and there was corrosion so I cleaned them up and put anti corrosion on terminals
 

·
Super Moderator
2017 SS Sedan 6.2L
Joined
·
5,331 Posts
It'll take maybe a week or 100 miles to get the computer back to normal.
 

·
Registered
Joined
·
191 Posts
Discussion Starter · #5 ·
Been almost a month and a half since I disconnected battery terminals to clean them and then took the car the next day to get transmission fluid changed. for the first time in two weeks I had shift flare come back. Once on Thursday and couple times yesterday. Usually in the city where lot of lights and I get stopped at each one usually. I wanna say it's shifting from 3 to 4 or 2-3. The dealer told me it could take a few dozen drive cycles to relearn how I drive. But it's been over a thousand miles. I asked about a pcm reflash but kinda brushed it off. Thanks in advance.
 

·
Super Moderator
2017 SS Sedan 6.2L
Joined
·
5,331 Posts
Having shift flare as minor as the video you posted previously is not a big deal and probably doesn't mean anything bad. Did you show your video to anyone when you had the transmission serviced? What did they say?
 

·
Registered
Joined
·
191 Posts
Discussion Starter · #7 ·
I showed a family friend who's a Ford master technician and he thought the disconnectIng the battery cause that and give it time. I didn't at time of service. Lot going on. I talked to them after and posted it above. It's been doing it today and yesterday. I'm thinking to drive more aggressively to have it learn it. It's only in stop and go traffic when it does it. At lights. No check engine light on.
 

·
Registered
Joined
·
191 Posts
Discussion Starter · #8 ·
Now it does it around 2500 rpm if it does . Even if I not driving aggressively trying to get up to speed
 

·
Registered
Joined
·
191 Posts
Discussion Starter · #9 ·
Im disconnecting the battery for longer. I don't think when I did last time It was for long enough. It was only like 5 minutes. I am going to while I'm in class tonight. I got a shift flare 5 days in a row.
 

·
Registered
Joined
·
191 Posts
Discussion Starter · #10 ·
Monday I had to get a new battery since one in car wouldn't start it after being cold in Michigan. Had it tested after I drove around to charge it up and it said bad battery on the tester. I still got shift flares today. I don't get it. The car shifts fine otherwise.
 

·
Registered
Joined
·
191 Posts
Discussion Starter · #11 ·
I'm disconnecting the battery overnight. I don't think all the power gets out of the system that fast or a couple hours. It's just frustrating to see. My family friend who is a Ford master technician thinks it's a software problem.online seems to think it's slipping but I asked him if it was slipping, it would do it every shift and he said yes.
 

·
Administrator
2011 Malibu LTZ 3.6L V6 Red Jewel Tintcoat
Joined
·
19,082 Posts
It seems like your friend has some good thoughts about whether it's mechanical or software.

Have you been able to catch it on video yet?
 

·
Super Moderator
2016 Malibu 1LT 1.5T
Joined
·
3,054 Posts
Have you been able to catch it on video yet?
Yeah one from couple months ago. It's on a another forum I posted
Video:
 
  • Like
Reactions: DrivenDaily

·
Registered
Joined
·
191 Posts
Discussion Starter · #15 ·
Update: I had a dealer look at my car today that could. Place bought it from was busy and couldn't get me in today. I told them what was going on and said without codes and there's no "updates" for your car and it is internal issue. I said if it was internal, it would be doing it all the time and they said no. Says updates/ reflash are for when you have a code. People have got their transmissions updated without check engine light on in the Malibu forums. I've read them. People have got their transmissions rebuilt to have it still happen after. (I didn't say that but wanted to.) not trying to discredit them but I have done research and didn't seem interested in trying. Said they were busy but didn't seem like it to me. I called my dealer I got the car from and told them what they told me and said there's no way they checked for updates in two minutes. It takes 15 to 20 to check. If there's no updates and we reflash, it could be internal. My thought process is if I was. Would've thrown a code. Monday I go to dealer I got car from so I'll update more later.
 

·
Registered
Joined
·
191 Posts
Discussion Starter · #16 ·
Update : there was update for my tcm. 140 dollars later. I can tell a little bit now but I'm pretty sure it reset the adaptive transmission settings but I'm happy I had it done. Even gave me paperwork for proof of being updated
68777
 

·
Registered
Joined
·
191 Posts
Discussion Starter · #17 · (Edited)

Driving making couple more stops and I noticed it did the shift flare again couple times so I drove and got another on camera when I could or thought so. I mention in the end of the that it did it but watched it over and over and nothing noticable. Thoughts? Hasn't been 20 miles since update and I'm sure it needs few hundred miles to get adaptive stuff in order. Cause I think the reprogram gets rid of stored info with the update. Beginning to think my brain is playing tricks on me.
 

·
Registered
Joined
·
191 Posts
Discussion Starter · #18 ·
Tonight turning at light I swear it did a little shift flare. I didn't have to stop and I think I was in 3rd gear and shifting to fourth gear.was maybe 1-200rpm unless I blinked during it and the rpms went up then down like normal as it shifted. I can never get it to do it again. What's frustrating about it. I personally think the update helped a lot. Once a month/twice I think it does it but I'll take that over multiple times a week and sometimes in the same day. I've decided to change the fluid every two or so years. I probably sound crazy. Another user on here has done his yearly and still is on original transmission 300k miles.
 

·
Premium Member
Joined
·
2,194 Posts
Every now and then a shift may seem weird going around a corner in all of my fleet as the miles go on them.
It's like the computer doesn't know what gear to go to. My Traverse doesn't do it as it's new but the rest of the fleet is over 70k miles and it happens occasionally, especially on a 10-15 mph roll around the corner. I'd say normal operation plus now your hypersensitive to it.
 
  • Like
Reactions: Doworkscotty
1 - 20 of 30 Posts
Top