Chevrolet Malibu Forums banner

1 - 20 of 253 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
My message board tells me to shift into park, after I have and turned the vehicle off. I then have to turn the lights off manually. When I exit my car with my key fob with me, it beeps 3 times and the dash lights remain on. Anyone know what could be the issue? I am calling my local dealership once it opens this morning.



EDIT by campb292 - Sometimes the actual fix for this "shift to park" issue gets buried as the thread grows but just in case someone is looking, see bulletin 18-NA-297. You can view the full bulletin text and actual cause and resolution here:

This possible issue affects all 2016-2018 trims - L/LS/LT/Hybrid/Premier. This bulletin can be performed by any dealer and will be free of charge under warranty. The cost seems to be about $700 if you are out of warranty and want the dealer to do the work. Some have recently haggled the price down ($150). You may want to take a picture of the error message and share the bulletin number if necessary since the issue is intermittent. There is a new fix shown in post #185 by user Ed Grimm that you might also try (at your own risk).
 

·
Super Moderator
Joined
·
1,795 Posts
EDIT by campb292 - Sometimes the actual fix for this "shift to park" issue gets buried as the thread grows but just in case someone is looking, see bulletin 18-NA-297. You can view the full bulletin text and actual cause and resolution here:

https://static.nhtsa.gov/odi/tsbs/2019/MC-10160118-9999.pdf

This possible issue affects all 2016-2018 trims - L/LS/LT/Hybrid/Premier. This bulletin can be performed by any dealer and will be free of charge under warranty. The cost seems to be about $700 if you are out of warranty and want the dealer to do the work. Some have recently haggled the price down ($150). You may want to take a picture of the error message and share the bulletin number if necessary since the issue is intermittent. There is a new fix shown in post #185 by user Ed Grimm that you might also try (at your own risk).
 

·
Registered
Joined
·
4 Posts
This looks like an ongoing issue and dealers are reluctant to fix. My Chevy Malibu 2014 2lz does the same and its so annoying. I took it to the dealer, the dealer says the technician did not find any error code and it did not happen when the technician wanted to see. The time I gave the car to the dealer with the problem on it even noticed by the service person. It does at least 90 percent of time and I am scared to get out of the car. It looks like the dealer is lingering to have me out of warranty period expired.
 

·
Registered
Joined
·
2,824 Posts
Hi Bharat,

We’re sorry to hear you’re experiencing this concern with your Malibu, and understand how worrisome this must be. We assure you that your safety is of the utmost importance to us. If you would like for us to look into this further, and reach out to your dealership regarding further clarification, please let us know in a private message! Be sure to include your VIN, current mileage, contact information, and dealers name.

To learn more about GM’s privacy policy, please visit https://www.gm.com/privacy-statement.html

Bret B.
Chevrolet Customer Care
 

·
Registered
Joined
·
3 Posts
My 2016 is doing this also. It started last week. I am calling my dealer in the morning hopefully they will find out the problem --- Will keep you posted!
 

·
Registered
Joined
·
142 Posts
It is comforting to know Chevy customer service is monitoring this website to help solve unresolved issues. They have helped me in the past.
 

·
Premium Member
Joined
·
925 Posts
are you not in Park before you turn your car off???...maybe I'm misunderstanding the OP but...you should be in Park before you turn your car off...

Bill
 

·
Registered
Joined
·
16 Posts
It's also happening to me, after parking and turning off the engine, same message, keeps lights and radio on, have to turn on and off the engine until it detecs the parking position

Enviado desde mi Lenovo YT3-X90F mediante Tapatalk
 

·
Registered
Joined
·
72 Posts
Just started happening to me also. 2016 LT. Indicator on dash shows in P but error message after you turn off ignition says "shift into park" If you get out the radio and lights stay on. Sometime can get to stop by restarting and shifting through gears. Seems to be getting worse daily.
 

·
Registered
Joined
·
3 Posts
Well I took my car to the Dealer and if course during the time they had my car it didn't happen. But they did so a recall while they had my car! ? Of course 2 days later it happened again I had to let it run while I ran in a store because I just couldn't get it to turn off. I did manage to get it to turn off after shifting to park letting it idle and then turning off. I did take a video of it but th e dealer said they couldn't find what was wrong if it didn't do it while they had my car. I'm really afraid one time it's not going to turn off at work or some where that I can't let it run for a little bit.
 

·
Registered
Joined
·
1 Posts
My 2016 LT just started doing this last week. It is doing it about half the time. I plan to take it to the dealership this week.
 

·
Registered
Joined
·
16 Posts
2nd day at the dealer, i'll let you all know the results when they give it back to me

Enviado desde mi SM-G955F mediante Tapatalk
 

·
Registered
Joined
·
16 Posts
Still at the dealer, their going to change the whole shifter assembly

Enviado desde mi SM-G955F mediante Tapatalk
 

·
Registered
Joined
·
16 Posts
I had to wait for the error outside of the dealer to show them, jajaja

Enviado desde mi SM-G955F mediante Tapatalk
 

·
Registered
Joined
·
1 Posts
The problem is the shifter assembly there is a switch inside that only comes with the assembly the problem wont show on any error codes the dealerships tech will need to call gm tech support and they will advise them to replace the shifter under warranty as long as your warrantys still valid
 

·
Registered
Joined
·
16 Posts
3 day back from the dealer, they changed the whole shifter at no cost, no message since then

Enviado desde mi SM-G955F mediante Tapatalk
 

·
Registered
Joined
·
2 Posts
My 2016 Malibu is in for the same problem right now. Dealer says they have had a number of reports of this, but they have never been able to duplicate it. It happens to me at least daily now. But knowing my car, it will behave today. Had transmission hiccup and dealer was unable to duplicate that as well. On occasion my message center will say steering assist reduced when breaking. That too has never been duplicated. I have pics of the messages, but that doesn't seem to help once its at the dealer.
 

·
Registered
Joined
·
1 Posts
My 2016 just started this too. Almost every time I put my car in park and turn it off. I get a message saying "shift to Park". I'm pretty sure my warranty has ran out since I have about 65,000 miles on it (due to my long commutes) has anyone had the same problem? If so, what was the result?
 
1 - 20 of 253 Posts
Top