Chevrolet Malibu Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
So I not so long ago switched out the battery for the auto/stop function because the auto/stop voltage was low in the old one. The car was functioning normal afterwards when coming to a red light or stop. Then my car started to switch off completely while gear still being on drive. It’s happen multiple times where I come to a stop or red light and the car auto/stops then when I let go of the gas, rather than coming to a normal drive mode it seems to loose power and shuts off. I end up having to put my emergency lights on, putting my car in park, and switching the in engine off then on again to restart my car. I have no idea why this is happening. My car doesn’t detect that’s something is wrong either. I need help !
 

·
Super Moderator
2017 SS Sedan 6.2L
Joined
·
5,576 Posts
That sounds a bit more urgent than what we can do for you here, a trip to the dealership is probably necessary.

Did you use a proper factory-replacement battery or did you buy a cheap replacement from a place like pep-boys? A problem like you described should have set off some computer fault codes, can you have the codes read and post the result here?
 

·
Administrator
2011 Malibu LTZ 3.6L V6 Red Jewel Tintcoat
Joined
·
20,672 Posts
Thread moved from Gen9 section.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top