Chevrolet Malibu Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hey peeps, hope your ok during this stressful period in our history.

I have an unusual problem. I was driving my 2015 Chevy Malibu LT with the 2.5 liter engine, and it lost power. I look at the dash, it's lit up like a Christmas tree with the stability control lights on, engine light on. It was like in a limp home mode. I got the car out of traffic, and shut it off, then I restarted it. Everything was fine then, no engine lights or anything. I took it home and parked it. I tried to pull codes from the computer, but there are no codes! Weird! Anybody had any similar issue with their 2013-2015 Malibu 2.5? The car runs fine now like nothing is wrong at all.
 

·
Premium Member
Joined
·
1,476 Posts
Check your battery connections. Clean, no corrosion. Many times battery related issues will not set any codes but will trigger all kinds of warnings.
Next is the battery itself may be going. Load test on it may be in order.
Did this happen when it was in Auto Stop ? If so the auto stop battery in the trunk may be bad or going bad. As a reminder you have 2 batteries.
 

·
Registered
Joined
·
22 Posts
I had a vehicle that did that a few times, the dash lights all lit up and gauges bounced.... Battery was on its last legs.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
Thank you all. I did replace the Aux 12 battery in the trunk with another AC Delco unit. I will check the main battery and see if it's bad or has corrosion.
 
1 - 4 of 4 Posts
Top